Select to view content in your preferred language

Configure ArcGIS DataStore 10.9.1 Error connecting to ArcGIS Server Machine

03-13-2022 11:11 PM
New Contributor III

I'm trying to configure ArcGIS DataStore 10.9.1 installed  on windows server 2019

with ArcGIS server Machine on Win2019. it is failed with error:

Could not connect to server on machine 'https:\\GISSERVERFQDN:6443'. ArcGIS Data Store or ArcGIS Server on that machine may not be running or the machine is not reachable at this time.

however, ArcGIS Server Machine is running and can connect to it on the browser.


0 Kudos
6 Replies
MVP Regular Contributor

Hi.  At 10.9.1 you don’t need to put the https or the port number it’s just the fully qualified domain name of the proposed hosting server:

do not use the web adaptor address.  It’s purely the name of the host machine.

also make sure you’re using the primary site admin account for the server.  Don’t use portal credentials?

also have you opened up all the firewalls?

Scott Tansley
0 Kudos
New Contributor III

Hi Scott.

 Thanks for your clarifications .

  • for using the , I think this help page from ESRI stated to use the port and https, However the help is for 10.9.1, Also I tried the server FQDN without https & port and returned the same error

  • I'm using the purely FQDN of the ArcGIS server machine.
  • could you please define which port shall be opened and is it only 2443,9876 for datastore?
0 Kudos
MVP Regular Contributor

I think that may be out of date.  We had to enter:

up until and including 10.7.1 but since then I have only ever entered: 

The web configuration form actually states:


I've seen people enter http://...:6443 and it fail, so stick to the example.

Which data stores are you installing on this machine?  There are different ports for each data store type.  Documentation is here:

   Ports used by ArcGIS Data Store—ArcGIS Enterprise | Documentation for ArcGIS Enterprise


Scott Tansley
0 Kudos
New Contributor II

What was your solution to this? I'm having the same issue even with entering host name and admin credentials. Thanks!

0 Kudos
New Contributor III

Hi Emily,

In the past we used:

in the data store config, but only up and including ArcGIS 10.7.1.

Since then I have only ever entered: 

The configuration tools adds the https:// and the :6443  if you try and enter the full path into the configuration screen then my guess is that behind the scenes it's trying to connect to:


which is clearly wrong.  Stick to the approach and you should be fine.

0 Kudos
New Contributor III

I had this same issue and resolved it with the following approach.

My normal hosting server URL is like this:

Here is what I tried (note that browsing to the site via web browser worked):

  1. and
  2. and
  3. The above 1 and 2 with port specified 6443
  4. and
  5. gis-prep (THIS WORKED)

So there you have it, with all the morning fluffing about, it works via "gis-prep" as the hosting server name.

Hope that helps some people.

Helpful Info:

This was an upgrade from Enterprise 10.8.1 to 11.1. 

0 Kudos