Select to view content in your preferred language

Ferderated server doesn't appear under the hosting server in the portal

982
7
09-20-2023 10:53 PM
coolgis
New Contributor III

Hi,

I am trying to federate arcgis 10.8.1 server with the portal.

I can see that the server is federated with portal and shows the green tick. 

But the server doesn’t appear under hosting server drop down.

I checked that the datastore is healthy and configured with the server.

I see this message every 5 min.

 

 

"The database server was found to be stopped. Re-starting it."

 

 

win event log:

 

The description for Event ID 0 from source PostgreSQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

pg_ctl: could not start server
Examine the log output.

 

 

 

The description for Event ID 0 from source PostgreSQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

pg_ctl: another server might be running; trying to start server anyway

 

 Portal Logs:

 

2023-09-21 13:44:54 AEST: [3968]: [1-1] LOG: database system was shut down at 2023-09-21 13:41:25 AEST
2023-09-21 13:44:54 AEST: [3896]: [5-1] LOG: database system is ready to accept connections
2023-09-21 14:43:55 AEST: [12568]: [1-1] ERROR: relation "hsu_okm79.sde_logfiles" does not exist at character 29
2023-09-21 14:43:55 AEST: [12568]: [2-1] STATEMENT: SELECT logfile_data_id FROM hsu_okm79.SDE_logfiles LIMIT 0
2023-09-21 14:43:55 AEST: [12568]: [3-1] ERROR: relation "pg_temp_5.sde_logfiles" does not exist at character 29
2023-09-21 14:43:55 AEST: [12568]: [4-1] STATEMENT: SELECT logfile_data_id FROM pg_temp_5.SDE_logfiles LIMIT 0
2023-09-21 14:43:55 AEST: [12568]: [5-1] ERROR: relation "hsu_okm79.sde_logfiles" does not exist at character 29
2023-09-21 14:43:55 AEST: [12568]: [6-1] STATEMENT: SELECT logfile_data_id FROM hsu_okm79.SDE_logfiles LIMIT 0

 

OS: Windows server 2019 

ArcGIS 10.8.1 Enterprise

 

Can someone help on how to get this resolved and get the server appear under hosting server please?

Thanks

 

7 Replies
MiguelParedes
Esri Contributor

Greetings @coolgis 

If you login to Portaladmin directory, and then go to Home > Federation > Servers  you should see the server that is federated with the Portal. and whether it is the hosting server:
WHNd23FmM1.jpg

If it is showing "hosted server" as above, then the server is federated and is the hosting server.  

Then click on the Validate link under Supported Operations:
This should give you a good bit of information about the federation that should assist in further troubleshooting.

Hope the above is of help.

Miguel
0 Kudos
coolgis
New Contributor III

Hi Miguel,

 

I have already tried this and validated Datastore as well . The issue i amnot able to see the server in the hosting server dropdown.

I get this 

 

Validate All Servers

 

Status:

success

Servers:

 

Server Id:

UZWwqavg

Status:

success

Messages

·  ArcGIS Server administration URL 'https://esri.xx.xxx.xxx.xxx/arcgis' is accessible.

·  ArcGIS Server 'https:// esri.xx.xxx.xxx.xxx /arcgis' version is compatible with Portal for ArcGIS.

0 Kudos
A_Wyn_Jones
Esri Contributor

Hi @coolgis,

 

Could you please go to the ArcGIS Server admin endpoint and check the security config?

This may show as the server function as blank, could you please update the Server role and function so that the function reads "Hosting Server" https://FQDN:6443/arcgis/admin/security/config

This may give you a more definitive reason as to why you can't set the Server role from Portal. 

"We've boosted the Anti-Mass Spectrometer to 105 percent. Bit of a gamble, but we need the extra resolution."
0 Kudos
coolgis
New Contributor III

Hi @A_Wyn_Jones 

This is what it looks like now. I can’t see where is the server role field ?

Thanks

A_Wyn_Jones
Esri Contributor

@coolgis At the bottom under-supported operations, you should see "changeServerRole" - change the Server function to HOSTING_SERVER. The example at the bottom of this page shows the correct value:

https://developers.arcgis.com/rest/enterprise-administration/server/securityconfig.htm

To be clear, this operation is normally done by Portal when you select "Configure Server Role" after federating the Server. You seem to be running into an issue in that regard and this step is to troubleshoot why that may be the issue.

"We've boosted the Anti-Mass Spectrometer to 105 percent. Bit of a gamble, but we need the extra resolution."
coolgis
New Contributor III

Hi @A_Wyn_Jones 

I changed server role to Hosting server from server side. But it still didn’t update the portal side server role.

This is separate question : how can I change portalurl in portal proprties field in server security configuration page?

When I tried changing it says " failed to update security configuration. Can't update security configuration as server is not registered with portal. one or more required propreties are missing"

When I update it from portal admin system properties..I get proxy error.

 

Thanks

0 Kudos
coolgis
New Contributor III

Hi 

This issue seems to be resolved now although i get some 502 errors when federating.

 

Thanks

 

0 Kudos