Cloning HFL between Enterprise installations using Jupyter Notebook: Invalid Token (Error Code: 498) & Portal asks to log into source to view item

315
4
02-25-2021 08:25 AM
LR2
by
New Contributor II

I am trying to migrate/clone layers from one Enterprise installation to another. The cloning seems to work; the specified folder is created and the item is there. However when I try to open it, I get a prompt to log into the source as if the item wasn't cloned but just referenced/linked. The notebook also throws error code 498, but that might be the same issue. What's the problem here? Here's the whole notebook:

55e8e648-af58-4c5b-8723-4d014d78c864.png

Tags (2)
0 Kudos
4 Replies
LR2
by
New Contributor II

Also trying to move a scene throws no token error but as expected it fails, just differently, as well.

Screenshot 2021-03-03 094827.png

0 Kudos
HenryLindemann
Esri Contributor

Hi @LR2, there is a attribute in the clone_items method called copy_data=False try setting it to True.

 

Regards

Henry 

0 Kudos
LR2
by
New Contributor II

Thanks, unfortunately that seems to do nothing, at least the error is the same as above. I followed this instruction video, which does not mention the copy method at all. Perhaps it should be reviewed if the shown methods actually work.

0 Kudos
LR2
by
New Contributor II

These instructions are also wrong: https://support.esri.com/en/technical-article/000022252

See "full script" at the bottom. Despite giving it a specific item ID, the script finds 45 items (but displays only one - the item with the specified ID). Then it throws 45 errors and finishes without having copied anything.

45 items will be cloned. See the list below:
can only concatenate str (not "builtin_function_or_method") to str
(...)
can only concatenate str (not "builtin_function_or_method") to str
The function has completed

 

 

0 Kudos