Changing default arcgis server port number using web adaptor

11-28-2012 01:09 PM
New Contributor III
ESRI documentation indicates you can readily change the default ports used by AGS (e.g. 680 or 6443) using web adaptor but does not indicate how you do this?  Having not installed the web adaptor just yet, can I assume this is simply tied back to the IIS port binding? 

0 Kudos
4 Replies
Esri Contributor
By default ArcGIS server communicates through ports 6080(http) and 6443(https)
However, if the web adaptor is installed say on IIS then the default port for http=80 and https=443 unless otherwise.

Installing the web adaptor allows you to communicate to ArcGIS server through port 80 rather than directly talking to
ArcGIS server's port 6080 or 6443. Usually these ports are not open especially if communicating through the organizations's firewall
or reverse proxy, so have the web adaptor communicating on these open ports(80 or 443) makes life easier.

The ports really don't change per say, the web adaptor still communicates to ArcGIS server through these ports either 6080 or
Direct communication to the server:

Through the web adaptor:

I hope the information is helpful
New Contributor III
Thanks Pete,

This builds on my understanding so thanks however I am still under the impression you can configure AGS default ports to communicate to GIS serves on ports of your choice.  E.g. if your web adapter needs to communicate to GIS servers via a firewall, and you are restricted for the ports it can communicate on, then you need to ability to do this (e.g. in a secure enviro where ports are locked down).  Can you indicate how this is achieved as this inferred in esri documentation.

0 Kudos
Occasional Contributor
You can change the default ports by editing the server.xml file here: 

C:\Program Files\ArcGIS\Server\framework\runtime\tomcat\conf\server.xml 

Look for a line like this and change the port value: 

<Connector maxHttpHeaderSize="65535" connectionTimeout="20000"   port="6080" protocol="HTTP/1.1" maxPostSize="10485760" redirectPort="6443" server=" "/> 

If you have SSL enabled, find the <Connector> line with SSLEnabled="true" and change the port value. With either of these, you will then need to restart the ArcGIS Server service for the changes to kick in. 

Don't do this unless you know what you are doing.  

Link that identified this for me:

Please note that this is not a suggested configuration. If you do this, there is a good chance you will break your server. The server.xml is not the only place the port is configured.
The best way to handle this is by using the web adaptor.

Thank you very much
0 Kudos
New Contributor

As per ESRI’s documentation it is not recommended to change default ports for:

  •          ArcGIS for Server
  •          ArcGIS for Datastore
  •          Portal for ArcGIS

As ESRI technical documentation does not provide any information for changing those ports. ESRI only provide documentation of using non-default ports with Web Adaptor for ArcGIS. Even in that instance, it is considered as rare cases where Web Adaptor cannot use default web ports 80 for HTTP and 443 for Secure HTTP. Otherwise, ESRI even recommends to keep the default ports for the Web Adaptor.

To protect the identity of Enterprise GIS Servers a reverse proxy is deployed within a perimeter network (also known as a demilitarized zone [DMZ] or screened subnet) that handles requests from the Internet and forwards them to the machines in your internal network. The forwarding of requests on behalf of the reverse proxy server masks the identity of the machines behind your organization's firewall, thus protecting internal machines from being attacked directly by Internet users. Additional security functions can be implemented in the reverse proxy server to further protect your internal network from outside users.

While it is possible to change the default ports that is not a configuration that ESRI would support.  Changing the default ports for ArcGIS Server, Portal, and/or Datastore may impact and/or break your ArcGIS Enterprise implementation.

0 Kudos