Cannot Register Database or Folder in ArcGIS Server

2803
2
12-23-2015 12:40 PM
TroyMullins
New Contributor

About two weeks ago, could not Validate an SQL database that had been fine for awhile.  Can connect and use data in ArcCatalog and ArcMap.  When trying to validate or create new registered database, the process spins until Server Manager times out and logs me out - no errors.  I can kill it any time with no errors either.  Tried route to register via publishing a service with one of SQL datasets within ArcMap and got this error:

DataStoreError.png

Client libraries are there and again, was working fine until a couple weeks ago.

Then tried registering a folder as a check and the same thing - process will spin endlessly until time-out or kill.

Logs don't reveal anything. Settings everywhere look fine.  Windows update?

Thanks.

0 Kudos
2 Replies
ThomasColson
MVP Frequent Contributor

I wish I had thought of this before ( )...

Can you register ANOTHER SQL database via either method (via the Server Manager Interface, or ArcMap -> Show Registration Page). This assumes you have another SQL instance handy...or know someone whom can grant you access. If you get the same error when trying to get to another SQL instance, than that narrows it down to the GIS server. If it works...than it's the SQL server. In either case, permissions are the prime suspect. Also try the same with a network share....a different one than the one you're trying...for registering a folder.

RebeccaStrauch__GISP
MVP Esteemed Contributor

Also check to make sure a password hasnt recently been updated, or the license that runs the AGS/SDE didn't time out, for example, if registered to an "EDN" license (Esri developement network) which must be renewed each year.