Cannot recover a feature service checkout

09-07-2015 04:24 PM
MVP Frequent Contributor

This is really perplexing me. Steps to reproduce:

Create a feature-service check-out (Create Local Copy for Editing) using any combination of client/server from 10.1 through 10.3.1.

Make a few edits, save and stop editing.

Trash your ArcMap document that referenced the checked-out edit. (This is the part where you reproduce a user error such as catastrophic computer failure, or they closed the map without saving it).

Of course, you've been down this road before so you know where the check-out feature service data is in .....\ArcGIS\FeatureEdits......

Right click on the geodatabase that held the checked-out feature data and your previous edits, and attempt to synch back to the SDE database that the FS sources from using either the Distributed Geodatabase toolbar or the Arc Toolbox Tool.

Failed: version not found....but it's there! I've tried this after cleaning out ALL OTHER versions, so there was no question of what version/replica to synch. Same error.

I can check in/out/in/out using Distributed Database tools hitting SDE directly all day long, move the checkout data to another computer, check it in, no problem.

So how do you recover a checked-out feature service geodatabase following some error or issue that caused the loss of the original ArcMap document? This happens to me a surprising number of times, a user for some reason will lose the map, either the computer/network just crashes or they close the map without saving thinking they could just start editing from the local-copy geodatabase the next day.

0 Kudos
0 Replies