Cannot configure HTTPS

4038
7
03-22-2015 02:10 PM
JerryGarcia
Occasional Contributor II

I cannot successfully configure AGS with HTTPS. 

With the selfsignedcertificate or one that I create, when I choose "HTTP and HTTPS", the server properties never change.  It always stays HTTP only.

I cannot get past step 4 below.  Please see my attached screenshots.  I appreciate any help.  Thanks!

Tags (3)
0 Kudos
7 Replies
Jayanta_Poddar
Honored Contributor

Hi Jerry,

Did you bind the SSL (https) site to port 443?

0 Kudos
JerryGarcia
Occasional Contributor II

This step is not in the following directions?

Enabling SSL on ArcGIS Server when accessed through the ArcGIS Web Adaptor

http://resources.arcgis.com/en/help/main/10.2/index.html#//015400000600000000

I cannot verify Step 4 below with the selfsignedcertificate  or my own that I create.

Enable SSL for your site

Steps:

  1. Log in to the ArcGIS Server Administrator Directory at http://gisserver.domain.com:6080/arcgis/admin.
  2. Browse to security > config > update.
  3. For the Protocol parameter, choose the HTTP and HTTPS option and click Update. This will automatically restart your ArcGIS Server site.
  4. After your site is restarted, verify that you are able to access the URL https://gisserver.domain.com:6443/arcgis/admin. If you do not get a response from this URL, ArcGIS Server was unable to use the specified SSL certificate. Check your SSL certificate and configure ArcGIS Server to use a new or different SSL certificate.
  5. If you are able to access the URL https://gisserver.domain.com:6443/arcgis/admin, browse to security > config > update.
  6. For the Protocol parameter, choose the HTTPS Only option and click Update. ArcGIS Server is restarted.
  7. Once the server restarts, test that you can access the HTTPS URL of ArcGIS Server, for example, https://gisserver.domain.com:6443/arcgis/rest/services.
JerryGarcia
Occasional Contributor II

I am still having problems. Is the dash in the server name an issue?  Should I rename the server? All suggestions welcome. Thanks!

0 Kudos
JerryGarcia
Occasional Contributor II

Help.  Certs/SSL/HTTPS not working.

0 Kudos
JasonStanton__GISP
Occasional Contributor

From what I remember SSL doesn't like self-signed certs.  Is it possible that your browser is just not letting you see it?  What do you see when you go to http://gisserver.domain.com:6080/arcgis/admin?...anything?  Have you tried with different browsers? Can you send a screen shot or two?

0 Kudos
TravisSaladino
Esri Contributor

Hi Jerry

The dash in the name of the server shouldn't be impacting this issue.

When you try to access the site's Administrator Directory through https at port 6443, what happens? You you get an error in response or does the URL "revert" back to the http address at port 6080?

0 Kudos
KennethOGuinn
New Contributor III

Hi Jerry,

Thanks for all the screenshots, it really helps the troubleshooting process!

Would you mind elaborating a bit more on what you mean by you cannot get past step 4?

Based on the screen shots it looks like you have successfully told the machine to use the  "cert" certificate, though in the other screenshot it looks like your security settings are currently set to "HTTP Only"

Is there an issue toggling the setting from "HTTP Only" to "HTTP and HTTPS"?

If you haven't done so yet, you will want to go to  http://win-3ve1pkt1fl2:6080/arcgis/admin/security/config and select the Update link at the bottom of the page, and toggle that setting to tell the ArcGIS Server to now use HTTPS.

I do want to mention that part of this process will stop and start the ArcGIS Server, so services will briefly be unavailable when toggling this setting.

Thanks and look forward to hearing back!

0 Kudos