ArcGIS Server Service Metadata not working

621
2
01-15-2020 10:17 AM
JaredFischer
New Contributor II

I have ArcGIS Server 10.5.0, Build 6491 running on a Linux instance, and I have several map services published from feature classes in a non-versioned PostGreSQL SDE.  I've been working on creating metadata for all of them using ISO 19139 format.  For all but one, I've been able to create metadata and import it to the service, then finish up the other specific sections.  For one of the services, I get errors saying "Format Unknown" and "Uploaded content not found" (see screenshot below).  I've tried changing the format between Item Description, FGDC CSDGM, and ISO 19139 and importing in each format, and each time the upload seems to work, and I can edit it, but when I save, close the metadata window, and reopen it, it's all gone and I get the same XML page with the same error notes. 

Is there something wrong with this particular XML file?  I've used the same workflow for four or five other services on the same server and they all work great.  Is there a specific place on the server that stores the XML metadata files?  I've looked, but can't find it.  I'm wondering if this one got corrupted somehow.  I've also tried republishing the service, but with no success.  Any help would be greatly appreciated!

0 Kudos
2 Replies
AndrewWhitman1
Esri Contributor

Hi Jared, 

Perhaps you can validate the XML format? I found a free site that could help: 

https://codebeautify.org/xmlvalidator

Also, can you verify that the following location exists and is accessible to the account running ArcGIS Server? 

"File:///C:\Users\\un\...\7.jpg" 

When comparing this file to the ones that are working, what is different? Are the other files named using numbers as well? (8.jpg, 9.jpg) The metadata should be in an XML format rather than .jpg, but ArcGIS Server also needs permissions to the location of any of these files. 

I also found a few instances where the upgrade metadata tool mitigated this type of issue. Have you tried this already? 

https://pro.arcgis.com/en/pro-app/help/metadata/upgrade-metadata-to-the-arcgis-format.htm

0 Kudos
JaredFischer
New Contributor II

Hi Andrew,

I should note, I was able to find the location of the XML metadata files in the services folder on the Server.  So, I tried replacing all of the contents in the metadata.xml file for the service that is not working with metadata I exported in the ISO 19139 format from the feature class in the SDE that the service is based on.  I pasted that into the metadata.xml file, and now it will at least display the metadata when I view it in ArcMap, but when I try to use the Import tool to add new metadata, or try editing it and adding new items, it doesn't take and no edits are preserved after I close and reopen it.  I'm guessing that this workflow is not ideal, but it's at least one step closer to working correctly; it does prevent performing updates easily though.

The XML validator returned an error with the XML, but viewing it in ArcGIS Pro, it recognizes it as being in ISO 19139 format.  When I try to upgrade it in Pro, it returns an error saying "Invalid pointer".  

The Server is running on a Linux instance, so it doesn't have a C: drive; do you know where I can look for those files on a Linux system?

Is there any way to "reset" the metadata file for this particular service?  Editing it manually seems problematic, but is this something that the Server will generate automatically?  Would re-publishing the service help at all?  I'm still not fully understanding how Server handles metadata files and how best to proceed..

0 Kudos