ArcGIS Server multi-machine license doesn't match

291
4
04-17-2020 09:36 AM
Highlighted
New Contributor II

I have two virtual servers:

  • ER-MARISS1
  • ER-MARISS2

I followed ESRI's web help page (Configure a multiple-machine deployment) to setup my multiple machine servers.

I shared a directory on ER-MARISS1 for the config-store and directories called:

\\ER-MARISS1\ArcGISserver

I mounted this directory on both machines. (Yes, I even mounted it to the machine where the directory exists)

Both machines have ArcGISserver (\\ER-MARISS1) (Z:) in their Network Locations.

I installed ArcGIS Server software (ArcGIS_Server_Windows_1071_169677.exe) onto ER-MARISS1.
I authorized it with the Software Authorization Wizard using the following license file:

EducationSiteArcGISServerEnterprise_ArcGISServer_889234.prvc

I created a new site on ER-MARISS1 pointing to the \\ER-MARISS1\ArcGISserver directory.

I then installed ArcGIS Server software using the same install file onto ER-MARISS2 and authorized it with the Software Authorization Wizard using the same license file.

Using the ArcGIS Server Setup Wizard on ER-MARISS2, I'm trying to join to the ArcGIS Server on ER-MARISS1 using the Join Existing Site option.

The Specify Site URL window opened and I entered the following information.

ArcGIS Server site URL: https:\\ER-MARISS1:6443

I supplied the administrator username and password for the ArcGIS Server site, which is the same on both machines.

A popup window opens displaying the following information:

Configuration Summary
Your ArcGIS Server installation is ready to be completed.
Click Finish to join the site https://ER-MARISS1:6443

I clicked Finish and receive the following error:


Failed to join the site xxxxx. The license of ArcGIS Server at xxxxx does not match with the license of the site running at xxxxx. All the machines in the site are required to have the same license.

 

I am using the same license file, same software, same OS version, same everything.  Have I missed something?

Thanks

Reply
0 Kudos
4 Replies
Highlighted
New Contributor II

UPDATE (April 20, 2020): 

I found online where someone mentioned checking the keycode files on their machines under:

C:\Program Files (x86)\ESRI\License10.7\sysgen

I opened the keycode files and noticed they were different.  I had, at one time, arcgis server loaded on these virtual machines but because of some unknown problem causing it to not work anymore I had to uninstall and remove all traces of ArcGIS Server but must have forgotten to remove these keycode files.  That's usually the case with ArcGIS Server software, it'll just spontaneously stop working.  Anyway, I deleted the keycode files and re-activated using the same license file.  Same error as before so I checked the files and noticed the codes in the new keycode files were still different.  So I just removed the keycode file from the second machine and copied and pasted the keycode from the first machine so they would be exact.

It still doesn't work, it comes up with the same message saying I have two different license files.

I have no idea.

I will continue looking online.

Reply
0 Kudos
Highlighted
Occasional Contributor III

I had this same issue and it was infuriating. I was trying to join a second machine to our existing site and I received this error message late at night as I was trying to do this during non-production hours (and this was after a couple of months of troubleshooting with Esri support on why I wasn't able to add a second machine to our site, un-related to the license issue though).

I was in a similar situation as you. I had a VM where I previously installed server and attempted to join it to our site. Part of the troubleshooting process (again, not for the license issue) was to un-install and re-install server. So that's what I did, but even though I used the same authorization file, it still wouldn't like the authorization file. I had to do a complete un-install and remove all evidence of any Esri files in the Program Files directory. Then finally do a fresh installation and it accepted the authorization file at that point.

If possible, I'd recommend installing server on a fresh VM. But I know that's easier said then done.

Reply
0 Kudos
Highlighted
New Contributor II

Thanks for the info. I've done it so many times that I'm a pro at uninstalling ESRI software.  Our virtual servers are at another agency so getting a fresh setup is almost impossible. 

Reply
0 Kudos
Highlighted
Esri Contributor

Good day guys,

One of the things that we may need to take a look at is that there are times when there is a second keycodes file found under the Program Files (x86) directory structure. 

I have included the path that I would use on one of my environments:

C:\Program Files (x86)\Esri\License10.7\sysgen

Check and make sure that keycodes is not the one that is getting updated when applying the authorization number. If that is not the case then please reply to this and we can then delve deeper into this to see what may be going on.

Reply
0 Kudos