ArcGIS Server having problems with Fonts

699
1
12-10-2019 12:45 AM
spiskulaspiskula
New Contributor III

Hello,

I have a Standalone ArcGIS Server 10.7.1 on Windows 2016. When I go to Server Manager>Logs i can see that my map services report issues with accessing fonts. This happens both to the basic default service  SampleWorldCities as well as a map service I published from ArcPRO 2.4:

WARNING10 Dec 2019 08:20:47Invalid embedded font encountered: CIMPATH=font_arial_ttf/font_arial_ttf.datFontsave_Light_3857_201912091756.MapServer8776MapServerX::InstallTempFonts
WARNING10 Dec 2019 08:20:39Invalid embedded font encountered: CIMPATH=binaryreference/font_esri_11_ttf.datSampleWorldCities.MapServer8932MapServer.Connect
WARNING10 Dec 2019 08:20:39Invalid embedded font encountered: CIMPATH=binaryreference/font_arial_ttf.datSampleWorldCities.MapServer8932MapServer.Connect

The fonts are installed in the OS, so I wonder what does the warning really mean? Are they available to the MapService or not? How to make the Warning go away? I am concerned that if I run large caching work the fonts wont actually show on the tiles, so I'd much rather not to get any warnings and make sure all works fine in the AGS Setup.

ArcGIS Server is running on a Domain account that is a member of Local Admins on the VM

Regards

0 Kudos
1 Reply
RandallWilliams
Esri Regular Contributor

Check out this doc and see if the suggestions help.

Block untrusted fonts in an enterprise (Windows 10) | Microsoft Docs 

0 Kudos