ArcGIS Server 10.4 site missing

1832
7
02-23-2018 12:07 PM
Jay_Gregory
Occasional Contributor III

I had a fully functionality ArcGIS Servedr 10.4 site, but it has recently said the site is not initialized and prompts me to create a new site or join an existing one.  Through various troubleshooting, I've learned that the config-store-connection.xml and machine-config.xml files are missing from C:\Program Files\ArcGIS\Server\framework\etc, so I imagine my ArcGIS server doesn't think there is a site to begin with.  All of my server folders (config-store, arcgissystem, arcgisjobs, etc. etc.) are still available and aren't missing any content, it's just those two files.  My server is federated with a portal and also has a data store configured, so I don't want to blow the whole thing out, but don't really know what to do.  Is there any way to recreate those two files?

7 Replies
AustinMcNeal
New Contributor II

Hi Jay,

Though ArcGIS Server is not participating in a site, both Portal and Data believe Server is only unreachable (down for maintenance) and will patiently wait for Server to be accessible again. Therefore, do not unfederate Server from Portal.

These files go missing when ArcGIS Server is unable to reach the config-store specified, when a network drive is temporarily down when Server is starting up. If the config-store is on the same machine, Security scanners may temporarily quarantine the files, causing the connection to break. Once broken, Server may not be able to repair the connection on its own.

The content of these files are are specific to your deployment:


//config-store-connection.xml
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
<properties>
<comment>Configuration Store Connection Information</comment>
<entry key="status">Ready</entry>
<entry key="connectionString">C:\arcgisserver\config-store</entry>
<entry key="type">FILESYSTEM</entry>
<entry key="localRepositoryPath">C:\arcgisserver\local</entry>
<entry key="class">com.esri.arcgis.discovery.persistence.impl.FSConfigPersistence</entry>
</properties>

//


//machine-config.xml
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<Machine>
<MachineName>MCNEAL2.ESRI.COM</MachineName>
<Platform>Windows Server 2012 R2-amd64-6.3</Platform>
<Ports>
<OpenEJBPort>4000</OpenEJBPort>
<JMXPort>4001</JMXPort>
<NamingPort>4002</NamingPort>
<DerbyPort>4003</DerbyPort>
<HTTP>6080</HTTP>
<webSocketsPort>6180</webSocketsPort>
</Ports>
<WebServerMaxHeapSize>-1</WebServerMaxHeapSize>
<webServerSSLEnabled>false</webServerSSLEnabled>
<webServerCertificateAlias/>
<AppServerMaxHeapSize>256</AppServerMaxHeapSize>
<SocMaxHeapSize>64</SocMaxHeapSize>
<WebServerMaxHeapSize>-1</WebServerMaxHeapSize>
</Machine>

//

My config-store is on my C:\Drive, as wells as my Operating System is Windows Server 2012 R2. The "localRepositoryPath" will stay to a local drive. It would be preferred to copy these files from an existing machine.

If the above information is unhelpful, I would suggest reaching out to Esri Support.

- Austin

MarianMarigmen
New Contributor II

Hi,

Our client is experiencing the same error. Their server site is still accessible last week, but now the page displays the ArcGIS Server Configuration Wizard. When they try to create a new a site, it displays the "Failed to create the site. The configuration store location contains server configuration files that are being used by another site" error. I tried giving them a copy of the config-store-connection.xml (since the machine-config.xml still exists in their directory). But it still does not work. They also cannot access the rest endpoint of their services, but their Portal for ArcGIS is still accessible even though it is federated with the said problematic server.

Are there other ways to resolve this? Thanks.

-Marian

0 Kudos
StephanieWidas1
New Contributor II

Our 10.4.1 site "went missing" this morning, too - - after Microsoft Windows updates.  Any suggestions on restoring it?  I restored the config-store-connection.xml file (it was missing), but it didn't fix it.  The machine-config.xml file was still there.

Thanks,

Stephanie

0 Kudos
LubnyCity
New Contributor
I have the same problem. ASrcgis Server 10.6.1. Have you solved it? Thank.
0 Kudos
StephanieWidas1
New Contributor II

We were able to resolve our problem by restoring the c:\arcgisserver directory from a backup.  

NikhilBopardikar
New Contributor

Hi I'm having the exact same problem that occurred after a Windows AutoUpdate but I do not have a backup for the C:\arcgisserver directory. Anybody have a solution? This is an urgent problem for me. 

Lubny CityStephanie Widas‌  Marian Marigmen Jay Gregory do you have any suggestions?

RyanMurphy1
New Contributor

Same problem just happened with my arcgisserver directory.  Completely disappeared.  I've been in contact with ESRI support and Microsoft (server hosted on an Azure VM) and both don't have solutions for me.  This seems to happen occasionally and seems like a HUGE issue.  Can someone respond that this is being addressed, or with support?

0 Kudos