ArcGIS Enterprise Portal 10.9.1 Login Faliure

847
5
02-25-2022 02:27 AM
MuayadHussien
New Contributor II

872F6F03-EFF3-42A6-95BC-DF4EF6CED668.jpeg

AB39A679-4139-4274-B9B4-BA170A147353.jpeg

Hey there We’ve just got our arcgis enterprise 10.9.1 installed on a windows server 2019 working with a puplic ip linked to CloudFlare cdn and a firewall inside the network I set it up and configured the domain name and when i login to portal from outside the network it’s response as follow: (You don't have permission to access this resource.) and i can login from the arc gis apps like Collector and the other apps and i can even login to portal admin and server manager and server admin but when trying to login to portal  it’s redirected my request to this link https://mydomain/portal/sharing/oauth2/signin and here where is the error message come .

Tags (3)
0 Kudos
5 Replies
Scott_Tansley
MVP Regular Contributor

have you set the webcontexturl in portaladmin?  

Integrate your portal with a reverse proxy or load balancer—Portal for ArcGIS | Documentation for Ar...

 

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
MuayadHussien
New Contributor II

Yes i did but may i ask if there is a proplem when the local domain match the puplic domain exactly like my Active Directory domain is the same as my global domain name and I noticed the portal link is extremely slow when opening it from out side the internal network (online) 

0 Kudos
Scott_Tansley
MVP Regular Contributor

same domain shouldn't be a problem.  I have a setup where externally I'm something like:

 *.acme.com

and internally I'm:

  *.int.acme.com

But I use split DNS internally so my internal/external paths are all *.acme.com.  

The reason for slowness is more likely to be infrastructure/latency issues than esri.  That can get a bit tricky to resolve on a forum, so you might want to look at ping tests, and speeds between components or for a more advanced approach use something like wireshark.

 

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos
MuayadHussien
New Contributor II

Thank you very much I’ll do that i can reach every thing except the portal link  when i enter the username and password and click login error 404 (You don't have permission to access this resource.) shown it’s look like an a authorization proplem the wired thing i can login from Survey 123 app and the others phone apps on my phone with the same account but only on the portal it’s happening!

0 Kudos
Scott_Tansley
MVP Regular Contributor

Have you used developer tools in your browser to look at the network traces?  My guess is that the answer is there.  What URLs come up with a 401,404

or other?

Scott Tansley
https://www.linkedin.com/in/scotttansley/
0 Kudos