ArcGIS enterprise builder - editing hosts file instead of using DNS Alias

160
1
06-25-2021 07:11 AM
SamJakson
New Contributor II

An annoying limitation of the AGS enterprise builder is the inability to use a DNS alias. Has any one had success editing the hosts file and then running the  enterprise builder as a workaround to this?

I've seen it recommended here but have yet to see anyone post that this has worked for them. They seem to run into problems such as this and end up going the manual installation route...

Any information would be much appreciated as I'm looking to avoid the manual installation route but will have to if this hosts file workaround isn't an option. 

0 Kudos
1 Reply
JonEmch
Esri Regular Contributor

Hey there Sam, 

    This is something I have dealt with in my past with Support Services. In short, after much experimentation, there is no supported way of implementing a DNS alias during the enterprise builder installation (https://enterprise.arcgis.com/en/get-started/latest/windows/arcgis-enterprise-builder.htm#ESRI_SECTI...)

Adding an alias after the installation goes through will cause further issues since presumably ArcGIS Server will already be federated at that point. (https://enterprise.arcgis.com/en/web-adaptor/latest/install/iis/configure-arcgis-web-adaptor-portal....)

Others may have different ways or means, but I wanted to weigh in from my perspective. You will be better off installing ArcGIS Enterprise manually or via chef.

Keep on keeping on!
0 Kudos