Validate Relational Datastore from ArcGIS Server Administrator = 'invalid token'

1278
2
Jump to solution
02-17-2022 09:30 AM
TrinaNair
New Contributor III

Installed Enterprise ArcGIS 10.9.1.   Had validated the datastore with ArcGIS Server manager.   Month later, couldn't publish to the datastore.  Datastore unable to validate.  Also checked Server Administrator - 'Invalid Token'.  Tried unregistering and re-registering the Datastore.  DescribeDatastore - the "Portal for ArcGIS URL" is empty.  Also tried a test to run 'Updatelicense' - unable to generate a token.

TrinaNair_0-1645118821282.png

TrinaNair_1-1645118867741.png

Tried uninstalling and reinstalling the Datastore (was going to restore from backup).  Same result.  Checked Federation it validates okay.  Thanks

 

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
NaveenK
New Contributor II

Hello, 

I would quickly check if the ADMIN URL from Portal administrator directory page is showing up properly. 

I had a similar issue that Owning URL was missing and the solution was to update the ADMIN URL from ArcGIS server administrator directory.   

Regards,

Naveen

View solution in original post

0 Kudos
2 Replies
NaveenK
New Contributor II

Hello, 

I would quickly check if the ADMIN URL from Portal administrator directory page is showing up properly. 

I had a similar issue that Owning URL was missing and the solution was to update the ADMIN URL from ArcGIS server administrator directory.   

Regards,

Naveen

0 Kudos
TrinaNair
New Contributor III

Naveen - Thanks you so much.  That was totally it.  I was searching all over the place for that.  Thank you!!!!

0 Kudos