Unable to edit field names in Portal

842
5
02-08-2021 02:45 PM
Labels (2)
DeanHowell1
Occasional Contributor III

We are experiencing issues where users are unable to edit the field name in Portal for published data.

I have been able to replicate the issue but not been able to figure out why and wondering if someone can assist please?

In the example below, I am trying to change the attribute name from OBJECTID to OBJECT_ID and I can edit it but when I press save, nothing happens. I get the same result, regardless of the field name.

DeanHowell1_0-1612823883871.png

I tried to update the layer edit settings

DeanHowell1_1-1612823967443.png

But get the following error.

DeanHowell1_3-1612824110157.png

 

Tags (1)
0 Kudos
5 Replies
JayantaPoddar
MVP Esteemed Contributor

You cannot change the Field Name, once created. You can only change its alias name (display name).

You may be able to delete the user-defined Field (after creating new fields and transferring their values). You cannot delete a system-defined field (which seems to be in your case).



Think Location
DeanHowell1
Occasional Contributor III

Hello @JayantaPoddar , yes sorry I was not more specific, it is the alias I am trying to change but not able to do it. I can edit the data and display the data fine just can't change the field alias.

Does anyone have any idea?

 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

If you are the owner of the content and still facing the issue, please try 

  • logging out of Portal
  • clear browser cache and close the browser
  • login again, and try changing the alias name

else try a different browser.



Think Location
DeanHowell1
Occasional Contributor III

Thanks @JayantaPoddar, it is looking more like a federation issue at present as portal is trying to access the wrong site for admin type functions.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Then you should raise a case with Esri Tech Support. They can further drill down to the root cause of the issue.

Please let us know the cause and solution once the issue is resolved.



Think Location
0 Kudos