Search Bar sending anonymous users to login

09-28-2021 02:41 PM
Labels (2)
New Contributor

Hello everyone,

I'm building a dashboard that will have a layer I want users to be able to search on. The Dashboard and all its layers are set to public so anonymous users can access it. I've added the layer I want to search on to the searchable layers option in the map settings and I am able to search on said layer in both the dashboard and the map layer itself. 

I've successfully shared the URL with users in the company who do not have ArcGIS accounts and they are able to move around in the dashboard. However, when they try to access the search bar they are sent to an ArcGIS login screen, of which they do not have. 


I'm a User Type Creator, Publisher Role and I worked with a Admin of the ArcGIS enterprise portal to troubleshoot why anonymous users are being told to log in. We found this page and ran through almost all the options. 

Problem: Login credentials are required to access publicly shared layers or feature services (esri.c... 

All the layers are set to public.
There are no attachments on any of the layers.
The Allow anonymous access to your organization toggle is set to enabled.


The Admin tried sharing a map an anonymous user and had the same issue I did, so its not related to restrictions in the publisher role.
The Dashboard has no premium widgets (unless the search bar itself is a premium widget?)

The issue occurs even when a completely empty map with no layers is shared by the admin to an anonymous user, they are still prompted to login.

The only thing we haven't tried yet is the Disable Secure Sockets Layer. We wanted to check with users here if there is a solution we are not seeing. 

Thanks for any help or advice in advance.

Tags (2)
0 Kudos
2 Replies
MVP Esteemed Contributor

That usually means your portal's default locator isn't shared publicly.

- Josh Carlson
Kendall County GIS
New Contributor

Thank you for the suggestion Josh,

I'll check with the admin on that and let you know if that was the solution.

0 Kudos