Scene layer package (.slpk) and Portal for ArcGIS

1534
3
12-21-2018 06:33 AM
StefanaCioban
New Contributor II

I have recently installed and federated an ArcGIS Server and a Portal (10.6.1). I am using the server as a hosting one as I have installed and configured the ArcGIS Datastore (Tile cache and Managed) altogether with a registered enterprise database. Everything seems to work nicely when publishing different map image/elevation/feature layers. However, when I am trying to publish a .slpk, the process fails and I get the following error messages on both the server and the portal logs: 

"Failed to create couchdb database. Client tried to access password-protected page without proper authorization. (status code 401). Failed to execute (Publish Portal Service)."

I have done different tests, publishing both from ArcGIS Pro and the Portal, with "Add item from my computer" and I get the same errors.

 

The solutions that I have already tried are the following: 

Error: ERROR 001785: Unable to connect to the database used for scene caches (Unidentified Error) 


Error: ERROR 001784: Unable to connect to the database used for scene caches (unauthorized)
 

None of them worked in my case.

Any advice is welcome!

0 Kudos
3 Replies
Szu_NyiapTang1
New Contributor II

Hi, 

Did you manage to resolve this issue? I encountered the same issue recently.

0 Kudos
StefanaCioban
New Contributor II

Hello,

We have managed eventually as we created a common domain user for all three applications (they are hosted on 2 different machines) and reconfigured the users for each application to that particular one. Also, we configured IE to use ssl3 and added the portal and the server URLs to the list of trusted sites on both machines. I hope this helps. 

0 Kudos
Jack_Zhang
Occasional Contributor

Thanks for post and answer the question. We had the same issue after install 10.6.1. In our case we did run ArcGIS Server Account Configure tool to make sure the service domain account has all necessary access rights to the directories. But also seems apply the Trust Site settings in Internet Explore is necessary too as mentioned in Error: ERROR 001784: Unable to connect to the database used for scene caches (unauthorized) 

0 Kudos