Portal 10.3 Configuration Settings

9735
16
08-19-2015 09:58 AM
StephenWay
New Contributor

Hi Everyone,

I tried configuring a proxy using the PortalAdmin API by setting {"WebContextURL": "<url string>"}.  The update failed, so i thought nothing more of it, until portal stopped working almost immediately.

It failed, and now Portal starts, but i get a HTTP 404 when trying to navigate to the home folder.  It can see through console, that the HTTP404 is produced by the /sharing/.... request that happens.

The only HTML page i can now get up is the PortalAdmin login, and even my Admin username and password is giving me an error message "You are not authorized to use this resource".

So now, i cannot go into the Portal admin to change any settings, and i cannot go to Portal as a normal user to do anything!

I saw in one file in portal/framework/etc/portal-config.properties that the url i used to change the WebContextURL setting.  I reverted this back, restarted Portal and it is still not working!!

Is there some config placed into Postgres that i can get at to fix this?  I ahve spent half a day trying to resolve this - I have looked in every location & file that has been modified, and nothing is jumping out at me.

Many Thanks,

Steve

0 Kudos
16 Replies
PatrickJackson
New Contributor III

Greetings,

If this is a new install and there is no real content or configuration that needs to be preserved you can always start fresh and get it back up and working again. You can do this by:

1.  renaming or deleting the C:\arcgisprotal directory

2. uninstall Portal

3. rename or delete the install directory for Portal as well found at C:\Program Files\ArcGIS\Portal

4. reinstall the software

After completing this none of the old configurations or errors should be found on the machine and we should have a fresh starting point.

DustinHobbs
Esri Contributor

Hi Stephen,

What I would recommend is log into the PortalAdmin and remove the updated WebContextURL. Next I would complete the following

  1. From Portaladmin endpoint navigate to the following location:
    • Click on System --> Web Adaptors --> Click on the Machine name
  2. Next in the Address Bar at the end of the URL enter /edit
  3. Update the Web Adaptor URL to point to your Reverse Proxy address. Typically this will be https://reverseproxy/webadaptor
  4. Click Edit Web Adaptor

Once that is complete you should be able to access all the Portal for ArcGIS endpoints (Home, PortalAdmin, Sharing).

I hope this information helps.

0 Kudos
PhilipTickle
New Contributor

Hi Stephen

I seem to be having the same issue at the moment where by after i update WebContextURL i can no longer enter into portal admin so i can fix this. I found ortal/framework/etc/portal-config.properties but i dont see the url i entered in there.

So at the moment i can not longer enter the portal admin and cant login to portal itself.

Any pointers on this?

0 Kudos
DustinHobbs
Esri Contributor

Hi Philip,

Can you access any of the other endpoints? Home and Sharing? Have you tried to access the portal using the port number https://localhost:7443/arcgis/portaladmin

If sharing doesn't load then this points to some problem accessing the Portal PostgreSQL Database

0 Kudos
DarkoRadiceski
New Contributor II

Hi Dustin,

Tried to access that url and getting same issue.

If i try /arcgis/home renders an empty page

if i try /arcgis/sharing - page not found

all of this happened after i modified the WebContextURL in the portal admin.

Is it possible that is doing a double loop or redirecting to the wrong page

Ideally would be great if i can reset this setting

0 Kudos
DarkoRadiceski
New Contributor II

Also if i go to the arcgis rest endpoint and try to go the the hosted folder from before i get this:

Unable to load https://servername/arcgis/sharing/rest/portals/self?f=json status: 404

DustinHobbs
Esri Contributor

Hi Darko,

Ideally, you wouldn't make any update to the WebContextURL within Portal. Majority of the issues when you have to update the WebContextURL is actually fixed by completing the workflow I previously mentioned. This is also why I recommended removing the WebContextURL and completing this workflow.

  • From Portaladmin endpoint navigate to the following location:
    • Click on System --> Web Adaptors --> Click on the Machine name
  • Next in the Address Bar at the end of the URL enter /edit
  • Update the Web Adaptor URL to point to your Reverse Proxy address. Typically this will be https://reverseproxy/webadaptor
  • Click Edit Web Adaptor

Now if you are getting an HTTP 404 tells me that we're failing to reach the resource. This is most likely because of the update with the WebContextURL.

Now the problem is we can longer access any of the endpoints to make the changes required. If we could access the internal database for Portal for ArcGIS we maybe able to make an update to recover from the problem. Unfortunately, there is currently not a documented workflow to do such. Therefore, I'm afraid you may have to re-install Portal for ArcGIS.

0 Kudos
huangbinhua
New Contributor II

Hi Dustin,

I have the same problem with  stephen.

If i try /arcgis/home renders an empty page

if i try /arcgis/sharing - page not found

if i try /arcgis/portaladmin,  I cann't log in.

Unable to load https://servername/arcgis/sharing/rest/portals/self?f=json status: 404

workflow you support,I Can't understand,

Can you explain more,or post same screenshots to show how to operater! thanks!

  • From Portaladmin endpoint navigate to the following location:
    • Click on System --> Web Adaptors --> Click on the Machine name
  • Next in the Address Bar at the end of the URL enter /edit
  • Update the Web Adaptor URL to point to your Reverse Proxy address. Typically this will behttps://reverseproxy/webadaptor
  • Click Edit Web Adaptor
0 Kudos
hukesebastien
New Contributor

Hi,

When i modified the WebContextURL in the portal admin, i've got this message :

{

"error" : {

"code" : 500,

"message" : "Failed to update the system properties.",

"details" : null

}

}

I can not longer enter the portal admin and cant login to portal itself ....

0 Kudos