Select to view content in your preferred language

How to publish script or model creating mosaic dataset as web tool

349
0
05-26-2023 07:50 AM
Labels (2)
MoritzHackenberg
New Contributor II

I am trying to publish a Python script as a web tool, where a Mosaic Dataset is created. It flags missing data stores for /Footprints, regardless of wehter I chose copy all data, o register. The .gdb folder where the mosaic dataset is put in is registered as a datastore. It also flags "24046 tool calculate field cannot use VB expressions for services". Do I have to enter /Footprints somehow as a derived parameter?

arcpy.CreateMosaicDataset_management(arcpy.env.workspace, "S_col","25832", "1","8_BIT_UNSIGNED", "NONE")

When I run the GP tool in the GUI and publish it, it works, but I cannot see the resulting Web Tool in the Catalog Pane under the server. I see it only in the Portal tab, and when I double click it is emtpy. It also appears in the portal in the browser. Opening it in Map viewer opens a map with nothing to click/start.

I also tried a Model tool. There I can run the function in the Modelbuilder, but when I try to run it as a tool it says "non of the processes are ready to run".

I did the tutorial https://pro.arcgis.com/en/pro-app/latest/get-started/share-a-web-tool.htm and got to publish it, but when I try to run the web tool it says ERROR 100014: Summarize Within failed. When when I select "copy all data" during publishing, the web tool works.

Tags (2)
0 Kudos
0 Replies