Geoprocessing printing tools Error

01-31-2018 02:43 AM
New Contributor


I am using Portal for ArcGIS 10.5.1, and I cannot print using the geoprocessing printing tools.

After configuring the GP printing tool, I could print my map from the web app builder application but not the Basemap.

But after some days, when it tried to print again, I was getting an error message.

As shown here below:

This is the error I get from the ArcGIS Manager logs:


My server is using a proxy.


Is there anyone who went through the same error?



0 Kudos
4 Replies
Esri Esteemed Contributor

Some simple questions (which may not be related):

  • The error mentions that you are using OSM. Does this error also occur when using a different basemap from ArcGIS Online?
  • Is the OSM website white listed on your server?
0 Kudos
New Contributor

Yes , the same happens when I use the World Topographic Map from 

No, it is not blocked

Thank you for your quick response


0 Kudos
Esri Notable Contributor

Strange how the error is indicating there's a problem with HTTPS security when the URL listed is over HTTP.  That may just be a red herring, though.  Microsoft's doc on those codes don't offer much: 

            The attempt to connect to the server failed.

I suggest trying to create a new webmap, search for the basemap over https, add it to the map as the basemap layer, (it should be added over https), and then print.  Another option, assuming you're on Windows, is to sign onto the Server machine and run Fiddler as the user running the ArcGIS Server service.  Then, when you try to print, Fiddler will capture all of the outbound traffic that Server is making and you can identify if outbound communication is blocked. I think the error is slightly different in that situation, (something about unable to establish a connection) but it'd be interesting to see what Fiddler comes up with.

0 Kudos
Esri Contributor

Does the forward proxy allow both HTTP  + HTTPS?

Does your web map have references to the Basemap using HTTP or HTTPS for the URLs? If you can check out the web map using and try switching your basemap URLs to HTTP:// that might help.

0 Kudos