Error: Unable to save your settings at this time

992
10
09-04-2018 02:50 PM
PawelGanczarski
New Contributor III

Hello,

I'm not able to save changes in "edit settings" tab in Portal for ArcGIS 10.6 (windows). I've applied the solution provided:https://support.esri.com/en/technical-article/000012316  without success. The text is the "organisation description" is short and simple. I've used the HTML editor to find problems with the text, but it appears similar to any text entered.

I'm baffled how else that can be approached.

Any help will be greatly appreciated,

Best regards, 

Pawel

0 Kudos
10 Replies
JeffreySutherland
Esri Contributor

Hi Pawel,

Can you share the text or html code that you are attempting to enter into the Organization Description field?

Thanks,

Jeff

0 Kudos
PawelGanczarski
New Contributor III

Hi Jeff,

Thanks for a prompt reply.

Sure, here it is : "Bienvenidos al portal de mapas comercial del Hub Geoespacial de Panamá"

 

Best regards,

Pawel

 

0 Kudos
JeffreySutherland
Esri Contributor

Hi Pawel,

Thanks for the text. Is this text being modifed in any way with extra HTML? Is your organization language set to English or another language?

Can you try the following:
1. Remove any text from Organization Description.

2. Click Save.

3. Open Edit Setting again and manually type in the text for your organization description (do not copy the text from another source like Word). Make sure you are typing the text within the text editor and not editing the HTML source (as per the referenced technical article).

3. Click Save.

Let me know if that works.

Thanks,

Jeff

0 Kudos
PawelGanczarski
New Contributor III

Hi Jeff,

Yes, I did follow these 2 steps, but the problem is that when I remove and retype the text or copy it from a text editor, it doesn't allow to save the changes.

Pawel

0 Kudos
JeffreySutherland
Esri Contributor

Can you post a screengrab of both the Text Editor Version and HTML source version of the text you are entering. See below for an example:

Text Editor Version:

HTML Source Version:

0 Kudos
PawelGanczarski
New Contributor III

Hi Jeff, 

Attaching the screengrabs

First text editor version:

and HTML version:

Thanks,

Pawel

0 Kudos
JeffreySutherland
Esri Contributor

Hi Pawel,

I can't seem to reproduce this on my end. Can you answer a few more questions for me?

  1. Was your 10.6 Portal upgraded from a previous version?
  2. Can you try opening the browser developer tools and monitor the network traffic when clicking Save after updating the Organization Description? It would be beneficial to know the request response from the https://portalmachine.domain.com/webadaptor/sharing/rest/portals/self/update request that is made.

Thanks,

Jeff

0 Kudos
PawelGanczarski
New Contributor III

Hi Jeff,

Answering the questions.

1. This Portal version 10.6 was upgraded from version 10.3.1

 Here the index status image 

2. I'm attaching the screen grab from Fiddler regrading the request made when attempting to save changes:

I hope this helps, 

Thanks,

Pawel

0 Kudos
PawelGanczarski
New Contributor III

Hi Jeff,

I have additional info that might be helpful to the case:

dojo.js:6 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.

r.getText @ dojo.js:6

Best regards, 

Pawel

0 Kudos