error about portal transaction logs taking more than 5GB disk space occurring multiple times a month even after full backups

929
5
08-19-2021 09:44 AM
Labels (2)
IngridMans
Occasional Contributor II

I'm having a few issues, but one thing that seems to recur too often is the portal logs filling up with the error: 

The transaction logs of the portal are consuming more than 5GB of disk space. Run a full backup using the webgisdr tool to clear out these logs.

 

even within a day after I ran the last full backup. I also have a published locator service that keeps failing, and restarting the service from server manager is not fixing. Server Manager logs referring to that locator say What gives? 

I have also been intermittently getting 'booted out' from having access to server manager, even though I'm an administrator. It seems to me that the authentication from Portal is tripping up somehow. 

 

**UPDATE** I think I found part of my problem, since the last time I had an Esri support call it seems I forgot to set the Portal log level from 'debug' to 'warning', so naturally those piled up fast. Our Portal machine still has been acting strange with authenticating various secure apps access to Server Manager, but I don't know if the error logs were related. 

Tags (1)
0 Kudos
5 Replies
JonathanQuinn
Esri Notable Contributor

16 MB transaction logs are generated automatically every hour, but can be generated quicker based on usage to the portal. At 10.9, we added a "backup" mode to the DR tool which does not remove the 5GB limit on the transaction logs, and will re-enable the limit if a backup was created using the "full" mode. Until then, you'll need to either clear out the transaction logs manually, (except for the most recent), or run a backup more frequently.

IngridMans
Occasional Contributor II

Here's my "stupid question"....where exactly are those logs getting stored? There's not that much disk space occupied in the 'logs' folder on our portal machine. 

I'm also not sure what to make of the 'refreshing log display' on server manager of running forever. 

0 Kudos
JonathanQuinn
Esri Notable Contributor

Not a stupid question! We don't document the log path. They're under C:\arcgisportal\backup\walarchive by default, or wherever your "default content" directory was when installing Portal.

I don't think that's related to Manager not returning logs. When I've seen it take a long time to get logs from Manager, or the Admin API, it's because Data Store wasn't in a healthy state and Server is waiting to collect logs from the Data Store. Try to restart Data Store as a relatively easy troubleshooting step, (during off-hours to limit downtime as necessary), and see if that helps.

0 Kudos
HenryLindemann
Esri Contributor
Hi @IngridMans,
Your portal is probably in some intense logging mode like fine or verbose, you can set it to warning and reduce the retention period to 30 days.
Also check if you have severe errors this is a indication of a problem and they tend to log every time the problem occurs.
https://henrycerttrain.esri-southafrica.com/portal/portaladmin/logs/settings/edit

[cid:image001.png@01D795A1.EDD547D0]
On WebGISDR it cleans out the portal .wal files -NB never delete the .wal manually- not the regular log files

Kind Regards
Henry

0 Kudos
HenryLindemann
Esri Contributor

Hi @IngridMans,

Do you ever add the services with the url for example https://henrycerttrain.esri-southafrica.com/hosting/rest/services/folder/name/FeatureServer/0 ? 

I have seen before that only the item with the itmeId controls the sharing.

Can you verify that the itemId in ArcGIS Server matches the ItemId in portal it is located under admin

https://henrycerttrain.esri-southafrica.com/hosting/admin/services/SampleWorldCities.MapServer

HenryLindemann_0-1629461432959.png

Have you ever unfederated the Portal ?

Regards

Henry

 

0 Kudos