DATAFRAME CLIP IN LAYOUT VIEW

339
13
08-01-2012 10:51 AM
nimitz
by
New Contributor III
Hey all,
I often have to place ZOOMED in areas of maps. The problem that I have is that the new data frame clips don't make a TRANSPARENT BACKGROUND. So, when you clip - the areas of the dataframe are white. I have played around with BACKGROUND and tried NONE but it ALWAYS makes the background white. Is there a way around this?

Thanks
Tags (2)
0 Kudos
13 Replies
LucasDanzinger
Esri Frequent Contributor
Hmm, I tried on 10.1 and 10.0 and cannot repro what you are seeing- if I set it to None or Hollow, they both look good and there is no background color. If you call in and create a support ticket, we can do a screenshare and try to figure out what is going on. But, None or Hollow should do what you are asking for.

-Luke
0 Kudos
nimitz
by
New Contributor III
I'm enclosing the PDF of what I produced.

[PDF removed on request from poster.]
0 Kudos
LucasDanzinger
Esri Frequent Contributor
What are you using to clip the data frame shape? Is it a feature class, specified extents, or something else? I used another feature class to clip and it does not have the background.
0 Kudos
nimitz
by
New Contributor III
What are you using to clip the data frame shape? Is it a feature class, specified extents, or something else? I used another feature class to clip and it does not have the background.


I created a shapefile to see if that might work, but it doesnt'. The data frame has been rounded 100% - to create a circular call out (this is the issue - when you round the data frame the back stays white.)

Remember, when I export to pdf OR if I print the .mxd, the white still comes in. Pretty frustrating.
0 Kudos
LucasDanzinger
Esri Frequent Contributor
Weird, I believe I am doing the same thing but it looks to be working for me. I'm at 10.1...
0 Kudos
nimitz
by
New Contributor III
Weird, I believe I am doing the same thing but it looks to be working for me. I'm at 10.1...

What's weirder is that when I'm in ARCVIEW, the transparency will stay consistent. It's when I print or export to pdf is when the transparency goes out the window. killin' me.
0 Kudos
LucasDanzinger
Esri Frequent Contributor
What version including service packs are you at?
0 Kudos
DonovanCameron
Occasional Contributor II
Does one of the layers in the data-frame have a transparency or a graphic inserted?

Any layers that have a transparency enabled will cause that "white" background effect and also, exporting to a vector based format will cause the white background to show up.

See: http://forums.arcgis.com/threads/21701-inserting-a-png-or-image

T
he workaround was to export the map to a raster like a jpeg, png, tiff...

I also found recently that if I used ArcMap's export to PDF (from File pulldown) it would show the white background.
I had to "print" the map using a PDF printer driver like "Adobe PDF" which would print the layout to a pdf file and that did not show the white background.
0 Kudos
nimitz
by
New Contributor III
What version including service packs are you at?


I'm on 10.0 with SP4, running on Windows 7 - "Microsoft for life!! j/k:D

Thanks for all the help and suggestions.
0 Kudos