Clone items fails with message "Access to admin resources are not allowed\n(Error Code: 403)"

499
5
10-01-2021 03:56 AM
Labels (1)
suryakant_cssl
New Contributor

Hello,

I am trying to clone some hosted feature services from one Portal (10.6) to another (10.8.1). I am an admin and logged in via OAuth 2.0 (with client_id) on both the Portals. The items are owned by another user but I am an admin on both Portals and I can view the layers in map viewer. The [clone_items] method provided in ArcGIS Python API is failing for all hosted feature services with the following message.

"('Failed to create Feature Service Wetlands: Access to admin resources are not allowed\n(Error Code: 403)', <Item title:"Wetlands" type:Feature Layer Collection owner:Surya.Kant@domain.com>)"

I am able to clone the scene services successfully but unable to clone even a single feature service due to the above message.

Any help will be highly appreciated.

0 Kudos
5 Replies
JakeSkinner
Esri Esteemed Contributor

Hi @suryakant_cssl,

If you have a built-in or active directory account for Portal, you can use the following tool to copy services:

https://community.esri.com/t5/arcgis-enterprise-documents/copy-content-between-portals/ta-p/920460

0 Kudos
suryakant_cssl
New Contributor

Thanks a lot Jake,

I will give it try and post back the results. 

Regards,

Surya

0 Kudos
conghuang1
New Contributor

I have the same issue, I want to try my own code, and for other layers the clone_items working fine, just for hosted feature service, has the same error.

0 Kudos
JTessier
Occasional Contributor II

We are having a similar issue (same error message), but just with automating publishing via the python api.

@conghuang1did you ever find a solution? 

0 Kudos
mgress12
New Contributor II

Following an upgrade to 10.9.1 we are now seeing this error message when using the python api to clone hosted feature layers. This was not an issue at 10.7.1. Any tips on getting this to work?

0 Kudos