Cannot add Attachment - Extension not Found

01-19-2018 12:02 AM
New Contributor

Hello we used Portal and Server version 10.3

When I try to add attachment to my feature service in Portal I have error message "Extension not found". When i check ArsGIS Server logs there is "Unable to process request. Extension not found".

My workflow is:

Publish map service with "Feature access" capability (has attachment is set to True)

I add this service as item to My Content to Portal

When i can edit data - add attachment  I have that error message "Extension not found".(I can see existing attachment)

When I open feature service in REST and open it in, I am able to add attachment.

Do you have any idea why i cannot add my attachment in Portal?

Is it even possible with federated service?

Could by problem with security? - certificate?

Thanks for response


Tags (1)
0 Kudos
4 Replies
New Contributor


Did you ever figure this issue out, I am getting same error, using the same workflow (Feature Service) but trying to sync edits back to server.



0 Kudos
New Contributor

Hi, Sorry I dont remeber.

We are already at 10.6.1 and havent this kind of issue

0 Kudos
Occasional Contributor II

Same problem here, but not with Portal but just a plain ArcGIS Server service published in AGOL. Version 10.6.1 and version 10.8.1. When adding the mapservice again, adding attachments works. Other editing operations work on the original, just not the attachments.

0 Kudos
Occasional Contributor


Recently had same issue when i tried to add attachment from browser.

I was using /featureserver/ in url and getting same error after adding attachment. 

after changing /featureserver/ to  /FeatureServer/ attachments starts workng.