ArcGIS Portal Editable Feature Service access issue

08-19-2020 01:51 PM
MVP Frequent Contributor


I have a feature service published with View, Update, Delete etc. to my Portal (10.6.1).

The feature service is linked to an enterprise GDB which is registered to the data store.

the Portal is Federated.

Using a Portal administrator account I can fully edit the feature(s).  I've assigned the feature service to a group, with full update capability, and the service happily sits in a web app where I can create, edit features - which are automagically updated in the enterprise gdb fc.

The issue is when I assign anyone who is not an Administrator account to the group, the 'feature cannot be added to the map', even though the feature is shared with access and update capability.

I've also tried creating a new portal role with different admin options to allow access (even created a role with every option ticked) but it strangely did not replicate the administrator account experience.

Granting an administrator role to the feature editors is not a palatable option!

Has anyone else struggled with this?

0 Kudos
5 Replies
Esri Contributor

Hello David,

What authentication are you using to access Portal for ArcGIS?

What error message are you receiving in the browser developer tool?

What is the behavior when a member is not assigned to the role?

Thank you

MVP Frequent Contributor

All sorted, was assigning the new role I created to the wrong user! (Will still need to play about with the role options and wish there was more documentation for this).

0 Kudos
Occasional Contributor III

Hi, I have the same workflow and similar issues.

My point feature service is published with 'Add, update and delete feature' in the configuration tab when publishing from ArcGIS Pro (2.6.1), the feature service is linked to an enterprise GDB which is registered to the data store and the Portal (10.7.1) is federated. I have a Publisher role and the table is registered in the Enterprise GDB.

In a new WebMap on Portal for ArcGIS, once on the Edit tab, I only get 'Feature creation is disabled for all layers.' in the table of content. Although my layer should be editable. I can only Update attributes and Delete features. But I cannot Move or Create features...

Is there any setting/parameter missing?

For info: in ArcGIS Pro, I can Add, Update and Delete feature from the same point layer stored in Enterprise GDB. And any changes appear in the WebMap.

0 Kudos
by Anonymous User
Not applicable

I'm running into the same issue. Were you able to find a solution for this?

0 Kudos
Occasional Contributor II

Solved! It was a sharing issue, I had to grant "Access and Update capabilities" to the feature layer for the group.


I am having the same issue as the original poster. I have to assign an administrator role to the user, if not they get an error loading the map, "The layer, xxxx, can not be added to the map." Once I switch them to an administrator role everything works as it should, but that is not a solution,

Running enterprise 10.7.1

0 Kudos