"Clip Output to Graphics Extent" option disappeared

4415
8
02-08-2014 09:36 PM
EtienneBresciani
New Contributor
Hi there,

ArcMap has this essential option of "Clip Output to Graphics Extent" when using File -> Export Map. Well, this option has just disappeared from the Export Map window. I don't know how to get it back, and this drives me crazy. I know it is supposed to be there only when trying to export from the Layout View, so I am in Layout View. Here is a supporting screen shot:

[ATTACH=CONFIG]31267[/ATTACH]

Any one having that problem?

Cheers,
Etienne
Tags (2)
0 Kudos
8 Replies
LeonardLuz3
Occasional Contributor
Hi there!

I'm currently running ArcGIS 10.2 and I still have that option as you can see on the screenshot [ATTACH=CONFIG]31277[/ATTACH]. That's kinda weird coz you're already in layout view but the export dialog box is still showing what it should be showing when you're in Data View. Hm?
0 Kudos
EtienneBresciani
New Contributor
Update: back to office today, and problem solved. Sofar my only guess is that the problem is related to the connection or not of an external screen to my laptop, since I am using one at work and not at home and that the problem is likely related to the window size (it can be seen from my screenshot that the Export Map window does not seem to display entirely). More precisely, my guess is that ArcMap somehow saved a certain screen ratio, which would subsequently always be used (wrongly) when creating that window.

Otherwise, it just means that I should not work at home during week-ends :)

I'm running ArcMap 10.1.
0 Kudos
SamLockshin
New Contributor

Hi Etienne:

I'm having the same issue as the one you're describing (in fact the bottom-right window corner is also buggy on my Export Map dialog box and the "Write to Word" option is greyed out as in your screenshot). I work remotely using VirtualBox lots of the time on my MacBook (which could be the cause of many problems from the start), and it'd be beneficial to fix this bug. When I use the university computers, I also don't experience the issue.

I agree that it is a screen issue that arises when ArcMap communicates with Windows. Do you know of any solutions? I'd even take an arcpy workaround, if there are any (since the Clip to Graphic Extent isn't available with the arcpy.mapping module, ugh!).

Thanks for your time!

Sam

0 Kudos
SamLockshin
New Contributor

Etienne:

I fixed the problem for my case, it was just a matter of putting VirtualBox in full screen mode! It's definitely got something to do with the extent that you initially give ArcMap to display the dialog box. Giving it too little room will always clip the window. Apologies for not being able to fix the initial bug. I guess it's best to expand ArcMap as much as it can before launching the window.

0 Kudos
JaneDoran
New Contributor

Hi All,

PLEASE HELP! I am having this issue as well and  being an ArcGIS newby and would appreciate any assistance in simplified terms - ie. I have no idea what VirtualBox is!  Thanks in advance.

Regards,

Jane

0 Kudos
PaulDavidson1
Regular Contributor

Jane:

Virtualbox is software to virtualize a Windows environment on a Mac.

From the various solution, it sounds like this is related to screen resolution, maximized views, etc...

Folks can help you better if you provide more info:  what version of ArcMap?  Are you on a Win PC or a Mac?  Desktop or laptop?  screen resolution, graphics card etc might come into play.

Because of that, this sounds like a problem possibly best handled 1:1 with Esri support. They can share your screen and get into the weeds with you.

Good luck

0 Kudos
FedorKorennoy
New Contributor II

Hi! I've got the similar issue. The option 'Clip Output to Graphic Extent' has disappeared after some manipulations with Export dialog window size. I'm running ArcGIS for Desktop 10.4 under Windows 10 on a laptop with 1366*768 screen resolution.

Any ideas? Thank you in advance!

P.S. the problem gets solved when enable 'Auto-hide the taskbar' in Windows, but returns back on disabling this option...

GregoryLuna_Golya
New Contributor

Lost the "Clip Output to Graphics Extent" too. Tried the many suggestions. Rename Normal.mxt and re-start, checked the Exportdlg setting in Regedit, enabled the "Auto-hide the taskbar" in Windows, tab-tab-tab-tab-space bar. Still don't have the clip option. Running Desktop 10.6.1 in Win10. Clip the white board in Paint has been my solution for images. Any additional fixes? Thanks, Greg

0 Kudos