ArcMap crashes on startup

Jump to solution
06-18-2017 08:13 PM
New Contributor II

I'm having a problem with ArcMap consistently crashing on startup, both existing and new MXDs. ArcCatalog opens without issue. ArcMap gives me a message saying "ArcMap has stopped working: A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

I've tried many of the solutions provided to those who reported the same problem. I've gone as far as uninstalling both ArcMap and Python and reinstalling, at least twice now. I had the problem with 10.4, and now in the process of trying to fix this I have tried to upgrade to 10.5 but had the same result.

I'm not 100% sure because I went a few weeks without using ArcMap, but the problem may have coincided with a recent Windows update. I am running Windows 10.

15 Replies
MVP Esteemed Contributor

I am using the latest version of Windows 10 without issue, just not the home-use license... the software is the same as far as I know.  I still would contact tech support because if there have been other instances, then they would have immediate solutions.  Repetitive wiping and reloading isn't going to help if the root lies elsewhere.  I would give it shot

0 Kudos
New Contributor II

Just getting back to this. 

I did a complete reinstall, Python too. I uninstalled Python and got back the version that comes with the ArcGIS installation. I am currently running 10.5.1 as of tonight, and Python 2.7.13. Still, same problem of crashing on startup. ArcCatalog still works fine. 

Seems really bizarre that this could be happening after starting from a clean slate. I guess it must not be so clean. 

I've tried going into the registry and changing the folder under PythonCore to 2.7-32, 2.7-13, 2.7-12, 2.7.32, 2.7.13, 2.7.12. All of those resulted in no crash message, the loading document stage ran extra long, and eventually ArcMap just closed with no message. Changing it back to "2.7" brought it back to crashing faster with the error message. 

I'll contact Esri next week. 

0 Kudos
New Contributor II

Problem solved. 

I spoke with Esri support. After a half hour of troubleshooting, it was determined that the problem was there were two display drivers running that were causing some kind of conflict. Under the Device Manager, Display Adapters, I had an Intel and NVIDIA driver running. We disabled NVIDIA and ArcMap and Google Earth started working fine. 

A subsequent Windows update re-enabled it and I had the same problem, with the same solution. This caused some other issues however. Just the other day I got some additional updates, including an NVIDIA update. Now I have both enabled and things are getting back to normal. 

Thanks everyone. 

Regular Contributor II

OK - just adding some knowledge here - if anyone else is using VMware AppVolumes and having issues running Arcmap whilst provisioning (getting the erro this thread is about) then I found disabling the VMWare SVGA 3D card enables you to run.

New Contributor

This solution also worked for me when ArcMap 10.8 had the same problem!

New Contributor

Problem Solved - Enterprise Version

I was having this same issue on a VMWare Virtual Machine, and disabling he VMWare SVGA 3D card did not make the application run. After almost two hours with esri support of troubleshooting and re-installations, the solution was to stop the Print Spooler service. Arcmap opened normal after this and continued to open and close smoothly.