ArcGIS License Manager 10.4 and IPv6 issue with Licensing Borrowing

10341
10
01-15-2016 03:04 PM
RichardDaniels
Regular Contributor

Here is an issue to be aware of for those upgrading to or installing a new ArcGIS License Managers for 10.4. I did this to support prerelease testing.

In my case I installed the new license manager on a fresh Windows 7 Professional (64 bit) install. I then updated the services.txt file as required to open the firewall to allow traffic between the FLEX LM manager and other computers on the network. I was then able to successfully checkout/checkin licenses from my ArcGIS Desktop 10.3.1 client and the ArcGIS 10.4 License Manager.

I then tested the Borrow license feature for ArcGIS Desktop Basic (client machine). This succeded. However, when attempting to return the license the ArcGIS Adminstrator (on the Desktop machine) would time out after about 20 seconds and return an error message. The Borrow/Return screen would then refresh and shown the license had not been returned.

This appeared to be a timeout issue, fixes such as adding the FLEXLM_TIMEOUT environment variable on the client (with values as high as 20 seconds) were tried but failed to improve the situation. On the host (license manager) machine we tried adding the computer names into the hosts table.

During a ping attempt while testing connections between the two computers we noticed that on the host machine it was returning the IPv6 address when pinged, when the same machine was pinged from the client machine it returned and IPv4 address. This turned out to be the problem. To fix the connection issue it was necessary to change the "priority" of the IP addresses. In Windows 7 and later IPv6 is the prefered/first addressed returned. To change the priority I used the Prefer IPv4 over IPv6 in prefix policies FixIt tool available from Microsoft for KB92985 (https://support.microsoft.com/en-us/kb/929852).

Disabling the IPv6 support on the network card itself worked as well but was not a viable longterm solution on our network.

Hope this helps someone.

Rich D.

10 Replies
JoshuaBixby
MVP Esteemed Contributor

Thanks Richard Daniels​, this could be potentially useful information for organizations transitioning to IPv6 and ArcGIS 10.4.

George_Thompson
Esri Frequent Contributor

Just adding some other groups for more visibility: Enterprise GISEsri Technical Support

--- George T.
0 Kudos
RichardDaniels
Regular Contributor

Now that ArcGIS License Manager 10.4 FINAL is out here is some additional information.

     The ArcInfo License Manager 10.4 just released is not the same version as the one included in the prerelease. To upgrade to the production 10.4 license manager you need to manually uninstall 10.4.50xx and install 10.4.5524.

     To use the concurrent use license option for ArcGIS Pro 1.2 you need to provision licenses from my.esri.com and then load them onto your license manager (similar to how you add ArcGIS Desktop licenses). Of note is that in the "Version" drop down, next to the "Authorize Now" button, there is a new Pro 1.2 option. This must be selected to authorize ArcGIS Pro. Secondly, after this is done and you hit "Authorize Now" to open the Software Authorizatio Wizard you will need to use the ArcGIS for Desktop radio button (there is no ArcGIS Pro option) to proceed through the authorization.I also had to cut and past the ECU license code, the wizard did not appear to honor the .pvrs file data.

I mention this because it was confusing to me.

Rich

0 Kudos
DonaldGrogg
Esri Contributor

Adding this for Direct Access customers. I have had users that have needed to make some other changes. Here is a summary of what they have done in order to get the License Manager connection established using Direct Access.

1) Lock the License Manager down to specific ports within the range of 27000-27009.

      Example: in service .txt file, change first 2 lines to read as follows:

         SERVER this_host ANY 27000

         VENDOR ARCGIS port=27001

2) Create 2 Inbound & Outbound Firewall Rules:

   a. Allow Ports 27000 & 27001

   b. Allow Program: “C:\Program Files (x86)\Common Files\ArcGIS\bin\ArcGISAdmin.exe”

   c. Allow Program: “C:\Program Files (x86)\ArcGIS\License10.4\bin\ARCGIS.exe"

   d. Allow Program: “C:\Program Files (x86)\ArcGIS\License10.4\bin\lmgrd.exe"

   e. Allow Program: “C:\Program Files (x86)\ArcGIS\License10.4\bin\lmutil.exe"

3) Set the preference IP6 over IP4: https://support.microsoft.com/en-us/kb/929852

4) Set the System Environment Variables:

   a. FLEXLM_TIMEOUT=5000000

   b. FNP_IP_PRIORITY=6

This should resolve the Direct Access connection to the License Manager. If it does not check with your IT staff for compliance using the following TechNet and WindowsNetworking articles:

10 things you should know about DirectAccess - TechRepublic

7 Steps for Troubleshooting DirectAccess Clients :: Network Troubleshooting :: Articles & Tutorials ...

Don G.

deleted-user-dZnlqqpQ3bzV
New Contributor II

We are running in to a similar problem but the solutions above did not help us.

We are migrating from Windows 7, ArcGIS 10.1 and VPN over IPv4 for network connections outside the office to Windows 8.1, ArcGIS 10.4 and DirectAccess over IPv6.

But the ArcGIS 10.4 license manager is totally unreachable through DirectAccess for ArcGIS Desktop 10.4.

ESRI inc. has checked every setting they could think of and nothing seems wrong.

Strangely enough ArcGIS Desktop 10.3 can connect to the ArcGIS 10.4 license manager through DirectAccess using exactly the same settings.

Anybody familiar with this issue? And perhaps solved it??

Kind regards,

Rienco Groenewold

Netherlands

DonaldGrogg
Esri Contributor

The first thing to check is that everything is set for either IPv6 over IPv4 (preferred) or for IPv4 over IPv6. Especially if you are changing from one to the other. If one machine is set one way and the other end  (client-to-server) is set to the other, chances are the request will timeout and they will not communicate.

They easiest way to do this is to simply run the appropriate 'FixIt' in the Microsoft KB 929852 

https://support.microsoft.com/en-us/kb/92985

Good Luck!

Don

deleted-user-dZnlqqpQ3bzV
New Contributor II

Tried both "IPv6 over IPv4" and "IPv4 over IPv6" on the ArcGIS Desktop client without any effect.

Problem is known to ESRI inc. through ESRI Netherlands.
They had a look at our license server en desktop client settings. Everything is supposed to be set right.But still no connection. Running ArcGIS 10.3 on the same client it works fine though!

DonaldGrogg
Esri Contributor

I was just able to finally reproduce the entire scenario. This not only can effect borrowing but can shutdown the License Manager as it eventually did in my test machine. Here is what I found.

Setup:

OS: Win7

Product: LM 10.4.1

Synopsis: Could not borrow licenses at first from the LM then could not connect to LM, eventually the LM stopped running. Tried to restart the LM. (LM service indicated that it was running, License Administrator indicated that it was not.) Tried stopping and starting the LM. Tried stopping the LM service. Could not get the LM running again.

Conclusion:

WARNING: The following "fix" required going into the registry which can render your machine inoperable if the wrong item is deleted or moved! Contacting Esri Technical Support is recommended.

Ran ProcMon and discovered that several registry entries were missing. Tried a REPAIR, No luck. Tried uninstalling and reinstalling, No luck.

Finally had to completely remove all directories and folders, remove registry entries and then run an uninstall to get everything cleaned out. At this point I ran a clean install using the "Run As Administrator" (even though I am an admin on this machine) in order to get it to work.

I will be submitting a bug on this however be aware that this has be very elusive and very, very difficult to reproduce so it may take quite a while to track it down.

In the meantime I would suggest that you contact Esri Technical Support if you run into this issue. Especially since it will probably require going into the registry which cannot render your system inoperable if you delete/move the wrong thing!

0 Kudos
RichardDaniels
Regular Contributor

If your IPv4 (preferred) over IPv6 settings are correct -and you can ping the server from the client (and client from the server) and Ping is returning an IPv4 address then I would fall back to checking your PORT settings. At Windows 7 and higher the Microsoft Firewall blocks the LM ports and you need top configure them manually.

See: http://desktop.arcgis.com/en/arcmap/10.3/get-started/license-manager-guide/configure-the-arcgis-lice...

There is also an environment variable you can set on the Client that increases the time-out setting used for license checkout/check-in calls. This setting is often needed in VPN or Citrix scenarios.

Rich

0 Kudos