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Workbench app is frozen in "Starting Translation..." or on the splash screen "Checking license..." message

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07-10-2025 11:53 AM

Workbench app is frozen in "Starting Translation..." or on the splash screen "Checking license..." message

Question

Why is the Workbench app frozen, how to fix this and what can I do to avoid this?

Answer

Customer case: Data interoperability extension fails to load or is frozen with Translation run. 
Customer description: when the workbench app is open and the user clicked on Run, the log stops on "Starting translation...".    Sometimes FME fails to load or stalls on the "Checking license" screen.
 
Condition: standalone workbench app.  Not manifested or not reported to happen when authoring the workspace of the ETL tool.
 
Screen captures:
Scenario 1: Translation is frozen
RenatoSalvaleon3_0-1752172806700.png

 

Scenario 2: When opening the Workbench app, splash screen is frozen on "Checking license..."
RenatoSalvaleon3_1-1752172806701.png

 

Diagnosis:
 
Scenario 1: This is a known bug where fmeobjectworker.exe or fmeworkbench.exe are not released as in-memory processes during authoring-testing cycle and the translation is run by the author. It is likely the Feature Caching is enabled. The freeze is triggered after making changes in the canvas and translation is run to the transformer or feature type where the change is made.
 
Scenario 2: Usually, the frozen splash screen with "Checking license..." is preceded by Scenario 1, after the user closes the app and attempts to open Workbench again.
 
Reproducible steps:
We don't have reproducible steps to trigger this bug. If you have reproducible steps to trigger this behavior, we'd love to have it.
 
Known workarounds:
1. Go to Task Manager --> Details tab and click "End Process tree" on any or all instance of fmeworkerobject.exe until the translation log starts running.
RenatoSalvaleon3_0-1752173250781.png

 

2. Restarting the workbench app works most of the time, although, it's possible that the splash screen behavior may happen.  If this is the case, ending the fmeworkbench.exe from Task manager 
3. If the above fails, restart your computer.
 
Suggested best practices:
1. Before re-running your translation and if your canvas objects display caches (Green or yellow squares to the left of the output ports),  go to the Tools menu option and click Purge Local Temporary. 
2. Disable Feature cache when in production mode
3. Use Feature caching sparingly. This would be counter productive for authoring but we believe there is a link between caching and this bug.
Version history
Last update:
‎07-10-2025 11:53 AM
Updated by:
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