Unable to share ops dashboard publicly. Need some help.

901
4
Jump to solution
11-28-2018 01:48 PM
RoryMcPherson__Stantec_
New Contributor II

Hi,

I am trying to share an operations dashboard publicly, however, I am still receiving a sign-in prompt when trying to access it from the url. It's a relatively simple dashboard that contains a single map and a single hosted feature layer view. The feature layer view is a public (non-editable) view of a private internal dataset we do editing on.

I have absolutely ensured the following:

  • Ops dashboard is shared to everyone.
  • Map is shared to everyone.
  • Hosted feature layer view is shared to everyone.

Is this an issue with publicly sharing a feature layer view of a group-only feature layer? Could it be anything else? This one is stumping me. Any help would be appreciated, thanks.

0 Kudos
1 Solution

Accepted Solutions
DerekLaw
Esri Esteemed Contributor

Hi Rory,

 

Please take a look a this thread, specifically Carmel's post,

Sharing Operations Dashboard Outside of Organization 

 

Hope this helps,

View solution in original post

4 Replies
deleted-user-qpvAI3Fo0MKR
Occasional Contributor III

I have used this exact workflow to publish this publicly shared Dashboard. The data are a limited view of hosted feature layer that is only fully accessible by an AGO group, so I'd say there's something else going on.

0 Kudos
DerekLaw
Esri Esteemed Contributor

Hi Rory,

 

Please take a look a this thread, specifically Carmel's post,

Sharing Operations Dashboard Outside of Organization 

 

Hope this helps,

RoryMcPherson__Stantec_
New Contributor II

Great thanks - all sorted now! Ended up just shortening the url to https://www.arcgis.com... to exclude the organisation and it worked.

SyedJawad
New Contributor

the possible work around is as follows ...may solve the problem:
First you need to enable the permissions to allow everyone to access your shared content outside your organization for that you need to first go to the home page of your organization…then go to the settings…..in settings tab go to the security on left side of the page…..within the security tab go to the policies and enable “Allow anonymous user option ’…shown in the picture…..then go to the sharing and share the dashboard again using short url and you will be good to go Arcgis Dashboard 2.pngArcgis Dashboard.png

0 Kudos