Show Popup URL Feature Parameter Not Functioning for Hyperlink

667
3
10-09-2023 05:04 PM
PhilipShutler
New Contributor III

Hello!

I have an issue with a URL parameter set for my dashboard to specifically show a popup for a feature. It is the one function the URL parameter is not executing. 

Currently, I have a main dashboard that has hyperlinks (Full Assessment Details) in lists that take folks to a simpler dashboard so they can get specific details on that feature. See below. 

BridgeList.png

The link to view full assessment details takes users to a simple secondary dashboard that contains a map of the features and has URL parameters. The URL parameters are set as feature parameters and are configured to zoom, flash, and show pop-up. I am using the Global ID as my unique identifier for my features.

When I click on a hyperlink (Full Assessment Details) it performs every action I have set: it takes the user to a new tab, opens the simple dashboard, and completes all the actions set in the URL parameters except showing the popup.  It zooms in on the feature and flashes it, but the popup does not display. This is odd because it clearly recognizes the Global ID for the feature and performs most of the tasks set in the parameters.  See the sample URL below:

URL.png

I opened up the developer inspection tools in Chrome and found this error pertaining to URL query parameters (seems relevant):

ErrorInChrome.png

ErrorInChromeScript.png

Another thing I should mention is that when you get taken to the feature in the secondary dashboard, after it zooms and flashes, if you manually zoom out a little and hit the refresh blue button in the bottom right-hand corner, upon reloading, it will zoom, flash and then show the popup (it's weird). 

I think to make it easier to get to the root of the cause; I will only focus on one feature since all of my features in the main dashboard use the same functionality. I'll focus on bridges for this example.

I'll go in order of how I set up the hyperlink in the list, using Arcade and HTML, then show the URL parameters for the secondary dashboard. 

In the bridge list, this is the arcade I have set up in advanced formatting and will use to produce the hyperlink in the line item template: 

 

var urlText = "{org_url}/apps/dashboards/7b327ca5cfa04293a146c9335af937fc" 
var globe_Id = $datapoint.globeID 
var url = urlText+"#bridgeID="+globe_Id 

 

Then, in the Line item template, I have this set as the source CSS/HTML code:

 

<p><u><span style="font-size:12px"><a href="https://{expression/url}" target="blank">Full Assessment Details</a></span></u></p> 

 

  These are the URL parameters set in the secondary dashboard for bridge features: 
 URLParam.png

 I have tried using multiple browsers, but the same issue persists for all the hyperlinks in my lists. The one list with hyperlinks that works completely is buildings in the main dashboard. I promise I have tried replicating what was accomplished in the buildings lists to the others, but I still get the same result (no popup showing). I know the main dashboard has many features, but I don't think that should affect the URL parameters in another application. I think it has to do with what is going on in the browser, cause the js error found using Chrome developer tools is very odd.


Any guidance on this issue would be much appreciated. 

3 Replies
thickj2
New Contributor

We are also experiencing this issue with our DOT dashboards. Have you submitted an Esri support ticket?

PhilipShutler
New Contributor III

No not yet, seeing if others in the community are experiencing this issue. Sound like it is occurring to other dashboards.  

0 Kudos
MattVRobinson
Esri Contributor

Hello @PhilipShutler!

I have seen this behavior appear when the web map the dashboard is using has a visibility range set on the layer in question. Specifically when the layer you are using in the pop-up parameter is not visible at the saved extent of the web map. As a workaround you can save the map at a zoomed in extent where all layers are visible, but that is only advisable in your case where the dashboard is only accessed via a link using the URL parameter that re-pans and zooms upon launch.

I suggest submitting a Technical Support case with Esri to get this logged as a bug or an enhancement for ArcGIS Dashboards. 

Great use case for the URL parameters and it's a good looking dashboard!