Problems with the widgets datasources when cloning dashboards

11-30-2021 05:32 AM
Labels (1)
New Contributor

Dear all

I have to migrate one Dashboard between two different ArcGIS Enterprise (AGE).

In the source AGE the dashboard is using a mapservice in the Webmap and a set of different widgets (basically indicators, lists and charts).

In the target AGE I created a Webmap but using hosted feature layers in this case (Feature Services). The layer list is similar.

I would like to automate the process migartion using the ArcGIS API for Python. As I have the id of both webmaps, source and target, I can use item_mapping with the clone_items function. This works fine for the webmap during the cloning process.

However, it does not work for the other widgets. If I check the ids of the other widgets in the origin dashboard, datasources seems to reference to a combination of the name of the webmap + "_" + number, as there is no specific id for a layer in a mapservice. However, in the destination webmap I can obtain those ids directly form the feature service.

Following this, I have tried two different ways:

- adding the origin id and target id to the item_mapping dictionary; however the clone process rises an error because it does not find the target layers ids (¿?)

- I also migrated the dashboard and, after that I tried to modify the target widgets datasource via the Python API. I do not receive any error ... but the datasources do not change in the dashbard (When I iterate again the widgets list the datasources are not updated .....).

Any solution, idea or workaround I can follow?

Thank you in advance

Jesus de Diego

0 Kudos
0 Replies