Pan and Zoom NOT working as actions in ArcGIS Dashboard

1690
5
04-08-2022 06:29 AM
RandyMcGregor3
Occasional Contributor III

I have several dashboards with pan actions configured on point locations. They worked fine until the upgrade to ArcGIS Dashboard. Now, when a feature is selected from a list, the resulting pan (or zoom) goes to a non-geographic place. I had a scalebar and the scalebar disappears after the pan - This suggest either that the pan is at a VERY zoomed in scale or has gone to a non-geographically valid area for some reason.

I have take off the pan action and rely on a filtered symbol to visualize the selected record. The user can zoom in and out all he wants, but the action-configured pan does not work.

These dashboards used to work, so something about the upgrade has introduced this problem. Has anyone else experienced this? Is it a bug?

5 Replies
jcarlson
MVP Esteemed Contributor

Can you link to a public dashboard that shows this? I've not seen this happen on my own dashboards.

- Josh Carlson
Kendall County GIS
0 Kudos
RandyMcGregor3
Occasional Contributor III

It may be a data issue, which I would not expect you to troubleshoot. This does not happen with all my datasets, but the one that is not working did work in classic dashboards so something has changed. I think multipoints confuse the new dashboards (based on different experience) but the layer I'm using here is not a multipoint - it's a simple point feature class.

 

0 Kudos
RandyMcGregor3
Occasional Contributor III

This appears to be specific to one dataset. I created a new one and it works. I would delete this post, but I don't know how.... Thank Josh for offering to help!

0 Kudos
Jmac
by
New Contributor

Hi,

I have a similar problem, with my category selectors. The zoom was working before the update for a filter by city. (filter with grouped values)
I wanted to add other filters on other perimeters since the update, but I couldn't select any move or zoom action, while the new filters are configured exactly the same way. It only works with categories since entities.
The most disturbing is that the first filter I had created before the update kept these features.

Kevin_Haynes
New Contributor II

I'm trying to create a dashboard with a map and a list, when you select a list item it zooms to the location. Simple right? Not so much. I'm using portal 10.9.1 and I have 2 rest services that are published by me. I have a point layer (sites) and a polygon layer (site boundaries). I put the services into pro, and set a scale dependency so the points don't show below 10k and the polygons only show below 10k. I also filtered the points using a definition query. After the scale and definition query, I published as a web map. When I set the list and action to the polygons, no action happens at all. No flash, zoom, pan, nothing. When the list is set to the points it zooms and pans to null island. But the flash action doesn't work at all. I've also tried to just bring in the service as it is without filtering or scale dependency, still doesn't work, the points zoom to null island. I thought this dashboard was going to be straightforward. 

0 Kudos