Operations Dashboard Browser Not Working

5041
14
05-16-2014 06:35 AM
JamesKellough
New Contributor II
I'm trying create a Single display operation view that can be opened in a browser and I keep getting the following error in all browsers I test:

Operations Dashboard Error
Ember.Object.create only accepts objects.
1c6b11e25bab41b992a3186742b4b80f


I have tried numerous views with and without widgets, with and without feature services - both editable and non-editable, with and without cached services. All views are shared with everyone in my organization, I've copy and pasted the share link from the Windows application as well as emailed the share links from the windows application and none of it works.

Out of perhaps 100 attempts to run my various views in a browser I was once able to view one in Firefox 28 but upon closing the browser and trying to reopen the view in the same browser it again failed. Has anyone else experienced this issues? At this point I don't know what else to change or test. Any thoughts would be greatly appreciated.


Environment settings


  • Windows 7 Professional 64x Service Pack 1

Operations Dashboard for ArcGIS



  • Product Version 10.2.3.536


Browsers Tested


  • Chrome Version 34.0.1847.137 m

  • Firefox 28

  • Firefox 29.0.1

0 Kudos
14 Replies
AlinaTaus
Occasional Contributor
I am also experiencing issues with the Web browser version. I do not get an error message, my page just does not load. I haven't done as much testing as James has I only tried IE, Chrome and Safari on an iPad.  I am pretty new to the Operations Dashboard but would really like to get this going. Maybe some from ESRI can address this issue?
0 Kudos
CarolGhostine
Esri Contributor
Hi James,

Are you able to share your operation view and webmap? Im assuming you can see the webmap fine using the map viewer in any of these browers you have tried? Are you able to try opening this op view on another machine?

Thanks
Carol
0 Kudos
JamesKellough
New Contributor II
Thanks Carol. My apologies, I should have posted this earlier, I realized my operations view was using a third party add in which I understand is not currently supported in browser views at this time. After saving a copy of my view with this add in removed it worked fine in my browser tests.   Cheers,   James
0 Kudos
CarolGhostine
Esri Contributor
Ok great. Glad you were able to get over your hurdle.
We are looking at solutions that would allow a single add-in to work in both the Windows and browser versions. Is there a specific kind of add-in you are wanting to build ?
0 Kudos
CarolGhostine
Esri Contributor
Hi Alina,

The minimum requirement to use ops dashboard on the iPad is 6.0 with safari. Does your op view have any add-ins?
Does your operations view open when using a desktop with your browser? If you like you can share your op view and I can take a look to see what could be the problem.

Thanks
Carol
0 Kudos
AlinaTaus
Occasional Contributor
Hi Carol,

I am not able to open the Operational View in any Browser. The only thing that works right now is opening the op view in the Windows version of the Operation Dashboard. The Op view has no Add-ins, just widgets.
Here is the link to the it:

http://www.arcgis.com/apps/dashboard/index.html#/c2a525221ad64b9a90df1a291f175791

Thank you for looking into this!

Alina
0 Kudos
CarolGhostine
Esri Contributor
Hi Alina,

I don't have access to this Operation View. Could you share it with everyone if you don't mind.

Thanks
Carol
0 Kudos
AlinaTaus
Occasional Contributor
I apologize, I just went it and changed the permissions and then edited the link. Let me know if it still does not work.
Thank you!
ALina
0 Kudos
CarolGhostine
Esri Contributor
Not sure if it takes time for permissions to update but as of now I still cannot access the op view. What is the name of the Op View?

You can email me at cghostine@esri.com and once we have a fix we can post it on the forum.
0 Kudos