Operation Dashboard - Fields w/ Date data types

4517
11
02-20-2018 11:50 AM
JordanMiller4
Occasional Contributor III

I don't understand how fields w/ Date data types could possibly generate a time.. " ,7:00" time at the end. See the img below. We're using the Portal dashboard. How do I prevent a time from showing?


11 Replies
DerekLaw
Esri Community Moderator

Hi Jordan,

Try configuring the Date attribute in the web map's pop-up property to remove the time.

1. Open the web map in the Map Viewer (either ArcGIS Online or Portal for ArcGIS).

2. Click configure pop-up for the desired layer in the web map.

3. In the Configure pop-up dialog, click Configure Attributes.

4. In the Configure Attributes window, select the date field and uncheck the Show time checkbox.

5. Click OK to save your changes.

This should remove the time stamp showing in the element, when you re-open the web map in Ops Dashboard.

Hope this helps,

AnninaHirschi_Wyss1
Occasional Contributor III

Hi Derek

In my dashboard I use related tables for the graphs and configured all the dates as 13/12/1997 (European, without time) in the web map. Yet the dashboard shows the dates as 12/31/1997, 12:00 AM. The charts either use the date field as value for grouping, or as category field when displaying features, for both cases "parse dates" is switched on.

Can you confirm this? Is this "as designed"? IMO, the dates should be shown as configured in the web map.

Thanks,

Annina

datetime‌

format date‌

date configuring‌

operations dashboard web version‌

DerekLaw
Esri Community Moderator

Hi Annina,

Apologies for the late reply, I was working at the EPC/Dev Summit conferences this week.

I'm not 100% clear on the details of your workflow, can you please send me an email, detailed repro steps and perhaps some data so we can take a look? Email: dlaw@esri.com

Derek

0 Kudos
RichardNicholas1
New Contributor

Hi Derek,

Did you find a solution to be able to display dates without the time in Operations Dashboard?

I have configured the pop-up in the web map to not show time however it does not apply this to the list in Op Dashboard.

Thanks,

Richard

0 Kudos
ChugachElectric
New Contributor III

Derek - 

We are experiencing the same thing as Richard Nicholas. I can configure the layer's popup in a web map and save it so that when I reopen the webmap, the "Show time" option is still unchecked. However, this doesn't change the list in the Dashboard, nor does it seem to be retained in the layer itself (which is the source for the Dashboard). When I open the layer in a new webmap (i.e. not the one I saved), the popup is once more set to show the time. Is there a way to edit the HTML in the Dashboard list to change the date format? Or make the Dashboard List element pull from a web map instead of a layer?

Thanks,
Jena

0 Kudos
RichardNicholas1
New Contributor

Hi Jena,

I have worked around this issue by first pointing the dashboard to a web map (adding the Map item using the +) and then selecting the layer required for the List from the web map. If you change the layer pop-up from that web map (to not show time), it shouldn't show in the dashboard either.

Cheers, Richard 

ChugachElectric
New Contributor III

Richard - 

Adding the web map itself to the dashboard worked like a charm. Once the map was in the dashboard I was able to access the layer with the formatted popup. This particular dashboard is entirely tabular data, so the map is just tucked behind the list widget. It's now extraneous to have the map as a widget, but it does solve the extraneous date issue, which is the more noticeable of the two.

Thanks for the idea,

Jena

0 Kudos
Fab_the_lab
New Contributor III

Great! Solved!

0 Kudos
RyanBohan
Occasional Contributor II

I am running into the same problem.  I have a table with dates only.  When I display it in a dashboard it adds a time stamp.  The problem is this also shifts the date by a day.  It appears to be a shift caused when appending data into portal.  For some unknown reason the table on portal wants to convert time.  (this is an error)

So if I do the work around to add it to a map and then remove time.  Its the day before.