Help with Dashboard Labels and extra fields being added to legend

347
2
Jump to solution
04-15-2021 05:48 AM
Labels (1)
ChristianPrzybylekPEMA
New Contributor II

Hello everyone,

I am having two issues with a recent Dashboard I made. My first problem is with labels – I have a map of Pennsylvania and its 67 counties and in the corresponding webmap I have the labels turned on to show county names. However, after I pull the webmap into the dashboard, some of the labels are hidden. Is there a way to force labels to show in AGOL? I also wanted to note that last week I was able to reduce the font to 5, and that worked for a while – using the smallest font settings available I was able to show all labels – but this week its back to not showing all of the labels.

A few things I have tried since include exporting a labels layer directly from Pro, and creating a tile and vector tile layer. Interestingly, the tile layer worked, but it repeated labels and was messy. Any advice or workaround is greatly appreciated!

My second problem is with how the legends of my webmaps display in the AGOL dashboard – this is also a new issue. Previously, my legends just had the name of the layer as it was displayed in the corresponding web map, in bold, and the categories being mapped. Now though, under the name, in unbolded font, its including the attribute field name.

For example, the layer is called Project Phase, and it is displayed data in an attribute field called “Phase”, and the legend now says:

Project Phase

Phase

1

2

3

4

Does anyone know why this happens and to resolve? Again, this was not an issue until this week.

Thanks!

0 Kudos
1 Solution

Accepted Solutions
jcarlson
MVP Notable Contributor

Best practice is to have a single issue per post so that you can get more focused responses.

As to the labels, those are being rendered on the fly in the web map, and visibility depends on your map's scale, rotation, etc. With the right settings, tiles or vector tiles could work. You'd have to address the label repeating issue in Pro prior to generating the tiles.

I'd suggest vector tiles myself, as those can be modified after the initial publish, whereas tweaks to image tiles need re-generating. Note that vector tiles do have a "place overlapping" option.

jcarlson_0-1618491904745.png

 

- Josh Carlson
Kendall County GIS

View solution in original post

2 Replies
jcarlson
MVP Notable Contributor

Best practice is to have a single issue per post so that you can get more focused responses.

As to the labels, those are being rendered on the fly in the web map, and visibility depends on your map's scale, rotation, etc. With the right settings, tiles or vector tiles could work. You'd have to address the label repeating issue in Pro prior to generating the tiles.

I'd suggest vector tiles myself, as those can be modified after the initial publish, whereas tweaks to image tiles need re-generating. Note that vector tiles do have a "place overlapping" option.

jcarlson_0-1618491904745.png

 

- Josh Carlson
Kendall County GIS
ChristianPrzybylekPEMA
New Contributor II

thanks for the advice! I will try that. 

0 Kudos