Select to view content in your preferred language

Filtering data on both feature and related join yields CANNOT ACCESS DATA error

197
0
03-15-2024 03:21 PM
Kwyo
by
New Contributor

AGOL webmaps with feature services and map services published in ArcPro 2.9.  I have a webmap that features a map service built with a related table join performed in ArcPro and then published to AGOL. I have a dashboard referencing this map service with indicators filtered for specific data display. In the past, this has all worked well, but now if I have two filters based on the feature attribution AND the join fields, I get an error of CANNOT ACCESS DATA and the attending yellow caution triangle.

With some testing I have figured out that if I have one or more filters on JUST the feature attributes, the indicator works. If I have one or more filters on JUST the joined table records, the indicator works. If I have a filter on the feature attributes AND a filter on the joined table records, it throws the error.

EXAMPLE. Feature point is a fire hydrant that has a field called "Jurisdiction" and the related table has a field called "Complete.  If I filter the data to be -Jurisdiction is equal to "Timbuktu" AND Complete is equal to "Yes" I get the error. Please note, the joined related table fields do show up as options in the filter list, and as I said, if I filter only on related records it works, so I don't think it's the join that is creating the problem.  

These map layers and dashboard indicators all worked just fine until recently when we 1. republished services via ArcPro instead of ArcMap and 2. the most recent updates to Map Viewer. 

Any ideas on what I need to change?

0 Replies