Select to view content in your preferred language

Dashboard Mobile View Displaying on Laptop Screen

2203
10
Jump to solution
07-17-2023 09:44 AM
Labels (1)
ArielLow2146
Occasional Contributor II

I configured a mobile view for my dashboard which for the most part works great but now when I load the dashboard on my laptop I see the mobile view. This isn't ideal because my laptop screen is a landscape orientation and the mobile view is designed for more of a portrait orientation. Is there any way to adjust the resolution at which the mobile view starts getting used?

1 Solution

Accepted Solutions
DavidNyenhuis1
Esri Contributor

Hi @ArielLow2146 and others,

We pushed an update to the mobile view logic. It is now based on your device/computer's screen size (instead of the browser's window size). If you could check again, that would be great. 

Thanks,

Dave

View solution in original post

10 Replies
JohannesLindner
MVP Frequent Contributor

There doesn't seem to be an option to specify the breakpoint for switching between the views. But you can modify your dashboard link to always open a specific view:

https://doc.arcgis.com/en/dashboards/latest/create-and-share/url-parameters.htm

Dashboard view parameters

When a dashboard opens, the optimal view of the dashboard automatically loads. If you have created a mobile view for your dashboard, that view loads when opened on mobile devices. When opened on a desktop, the desktop view loads. You can change the view by adding the appropriate dashboard view parameter to your dashboard's URL.

  • The view=mobile parameter loads the mobile view.
  • The view=desktop parameter loads the desktop view.

Have a great day!
Johannes
DavidNyenhuis1
Esri Contributor

Hi Ariel,

What is the screen size of the device? Only if the device is 600px or less should it open the mobile view.

Dave

Sabra-FRC
New Contributor III

Hi @ArielLow2146 , I appreciate you bringing this issue up. I just started using the mobile view function today and am experiencing similar issues.

@DavidNyenhuis1 , thanks for being responsive. I cant speak for Ariel, but in my situation my desktop is 1920 x 1080. So I am pretty confident that this must be some kind of bug with the mobile view function on Dashboards. Can you give any help or suggestions for fixing this? I also tried it with two different dashboards just to be sure that it was not a bug with a certain individual dashboard; The problem occured with both dashboards.

KenBouchard
Occasional Contributor

I have the same issue with one of my admin.  She sees the "mobile view" on her laptop when everyone else sees the "desktop view"...  Strange.

DavidNyenhuis1
Esri Contributor

Those impacted, could you provide the computer/device make and model, screen resolution, and browser used? 

Also, if you are able to share the link to the dashboard,  that would help.

If you are unable to share details in this thread, please reach out to Esri tech support and report this bug.

Sabra-FRC
New Contributor III

@DavidNyenhuis1 Thanks for responding David. My computer is an Asus Expertbook, with resolution 1920 x 1080. I tried this out on Google Chrome, Mozilla Firefox, and Microsoft Edge browsers and the issue occured with both of the dashboards across all of the browsers. I also tested it using Google Chrome incognito just to see, and that made no difference either.

Here are the links to my dashboards: Loss and Recovery Dashboard, and Residential Recovery Dashboard.  They should both be public and viewable.

 

Thank you for your help

0 Kudos
TimKuhn2
New Contributor II

Hi @ArielLow2146 , @Sabra-FRC , @KenBouchard 

I was experiencing something similar on my laptop (getting mobile views when my screen resolution was way over 600px tall as @DavidNyenhuis1 mentioned). When I would screen shot the viewable area of the browser/dashboard it would show the resolution was viewable area (with bookmark bar etc.) was 1915x857. Perplexed...

So in Windows 11 on my trusty Dell, I changed the scale from 150% recommended setting) to the 125% (see below). The setting is found under System -> Display -> Scale & Layout. For me, this solved the problem and I began receiving the desktop version of the dashboard as soon as I reloaded it in the browser.

Screenshot 2023-10-16 222846.png

If others find this to be the problem, hopefully the user's scale selection is something which the Esri wizardry could detect and perhaps account for when determining which interface to serve. But for end user support, the parameterized solution (#view=desktop) or changing display scale may help. I was also thinking about putting the link in the dashboard bookmarks for others encountering this. Something like "Force desktop view" with a link to the parameterized URL that @JohannesLindner mentioned.

Hope this helps,

Tim

DavidNyenhuis1
Esri Contributor

Hi @TimKuhn2 , 

Thank you for the details. The team is working on an update for the next release that better handles these scale/zoom situations. 

Dave

0 Kudos
DavidNyenhuis1
Esri Contributor

Hi @ArielLow2146 and others,

We pushed an update to the mobile view logic. It is now based on your device/computer's screen size (instead of the browser's window size). If you could check again, that would be great. 

Thanks,

Dave