BUG ArcGIS Dashboard Enterprise 10.9.1- Generate URL Preview

1320
9
Jump to solution
04-01-2022 06:58 AM
Labels (1)
Rodrigo_DaSilva
New Contributor III

Hello.
my english is not very good but come on....
We found the following BUG in ArcGIS Enterprise 10.9.1 Dashboards.

When a Dashboard is created, the generated URL is output with "..", breaking the Link.

Example:

Wrong URL: https://gis-teste.azureapp.com/portal../apps/dashboards/<ID_Dashboard>

Correct URL : https://gis-teste.azureapp.com/portal/apps/dashboards/<ID_Dashboard>

This portal was generated from an Azure image.

1 Solution

Accepted Solutions
AliciaShyu
Occasional Contributor

We're having the same issue, we upgraded to 10.9.1 a couple of weeks ago. 

Below is what support services sent me:

  1. Bug number: BUG-000145792
  2. Synopsis: When creating a dashboard in Portal for ArcGIS 10.9.1, the dashboard URL adds two dots after the web adaptor's name.
  3. Status: Fixed
  4. Workaround: Upgrade to ArcGIS Enterprise 11.0 

View solution in original post

9 Replies
STan_RWC
New Contributor II

Hi Rodrigo. Thank you for sharing this! Our organization just upgraded to ArcGIS Enterprise 10.9.1, and I went to check our own URLs after seeing your post.  We are also seeing this issue only on "Dashboard" items in our Portal, exactly as you described. 

AliciaShyu
Occasional Contributor

We're having the same issue, we upgraded to 10.9.1 a couple of weeks ago. 

Below is what support services sent me:

  1. Bug number: BUG-000145792
  2. Synopsis: When creating a dashboard in Portal for ArcGIS 10.9.1, the dashboard URL adds two dots after the web adaptor's name.
  3. Status: Fixed
  4. Workaround: Upgrade to ArcGIS Enterprise 11.0 
STan_RWC
New Contributor II

Thanks. It's good to know that this bug does not exist in ArcGIS Enterprise 11.0. "Upgrade to ArcGIS Enterprise 11.0" is a solution that we already know of. But some organizations need to do a few additional preparations before fully onboarding/migrating  to ArcGIS Enterprise 11.0, including migrating/rebuild certain applications that will be deprecated/not functional with ArcGIS Enterprise 11.0 and preparing different user groups and workflows to be acquainted with ArcGIS Pro since ArcGIS Enterprise 11.0 does not support ArcMap.  I believe  the message is now more for making sure that this does not occur in other future releases, so thank you for confirming that this wont exist in 11.0.  🙂 

OscarFigueroaOD
New Contributor II

Hi

Is there a fix for this without needed to upgrade to 11.  Have users on ArcMap so can not go to 11 yet.  Please address the issue at 10.9.1.  Thank you

0 Kudos
NAOMIPAUL
New Contributor III

We are experiencing the same issue with Dashboards created in ArcGIS Enterprise 10.9.1. We are also not able to upgrade to 11 due to required ArcMap tools from vendors. 

0 Kudos
ScottCorwin
New Contributor III

Just found this myself, are there any implications other than not being able to open the dashboard from the URL in the item description section?

 

0 Kudos
NAOMIPAUL
New Contributor III

No, you just have to remember to change the URL before sharing it. 

ScottCorwin
New Contributor III

Is it possible to change the URL displayed in the item details page?  I assume no, since the portal domain name is set by the web adaptor.  Not to mention just the work involved in hand change multiple dashboards.

 

0 Kudos
NAOMIPAUL
New Contributor III

We have utilized custom urls through our main website content management system. I haven't used it with Dashboards, but I imagine it will work the same.

Instead of ESRI URL

https://gis.gastongov.com/portal/apps/webappviewer/index.html?id=f03f7f9b3d3842b681e9f9a9e77fedb6

 

Custom Redirect

www.gastongov.com/RecyclingMap

0 Kudos