update failed: updates could not be sent

3828
1
11-09-2015 03:17 AM
simoxu
by MVP Regular Contributor
MVP Regular Contributor

Collector responds with the above error when I try to update attributes in the related table.

My circumstance:

publish feature service on the on-premise ArcGIS server, register the service in AGOL and make a webmap using the service. the firewall between the ArcGIS server and AGOL is not a problem, as I can view the service from the public domain.

I tried to get more info of the error, so I configured Fiddler as a proxy for my collector, here is the request and the response I captured:

POST https://utility.arcgis.com/usrsvcs/servers/xxx-item_id-xxxxx/rest/services/DCSIExt/RIASP2_LOCSA_Port... HTTP/1.1

RESPONSE:

{"error":{"code":500,"message":"Unable to complete operation.","details":[]}}

I don't see the utility service in my AGOL settings at all.

Can anyone shed some light on it?

Thanks in advance

Miaogeng Zhang

0 Kudos
1 Reply
simoxu
by MVP Regular Contributor
MVP Regular Contributor

Problem solved.

It's in the privilege settings for my db account.

I found the issue when I looked into the logs on my server, there was a "SEVERE" error, with message:

"Error: Insufficient permissions [table name]"