Unable to download offline map in Field Maps or Collector on Android

06-17-2021 06:29 PM
New Contributor III

I cannot download a map or map area for offline use.

I have tried Collector Classic 18.0.3, Collector 10.2.2, and Field Maps 21.1.0 on a Samsung Galaxy Tab A running Android 10, but none of them work.

In Collector and Field Maps I try to download a pre-defined map area, but after a few minutes (or an hour) receive the following error:

"An error occurred when downloading the map" and nothing is downloaded. It seems to hang up around 114 MB (of 821 MB).

I tried turning on Developer options in both Collector and Field Maps to look at error logs, but the only thing listed under Developer options is "Placeholder" which does nothing.

In Collector Classic I receive the following errors:

The map 'XXXXX' failed to download with the message: Untrusted server certificate from https://tiledbasemaps.arcgis.com/arcgis/rest/services/World_Topo_Map/MapServer/jobs/jcb915b3bf621...........

The map 'XXXXX' failed to download with the message: Read error: ssl=0xb3ebe378: I/O error during system call, Software caused connection abort

Trying again with Collector Classic, I received this error:

The map 'XXXXX' failed to download with the message: Unable to resolve host "tiledbasemaps.arcgis.com": No address associated with hostname

Several times in Collector Classic the map appears to download, but when I open it there is an error, "The map or data could not be loaded. Try downloading your map again." Sometimes, most of the map works, except for the USA_Topo_Maps for export layer [Living Atlas Tile Layer by ssemmens_hmhs, created Feb 5, 2015], which I downloaded successfully as part of a different map to the same Samsung Android device about 2 months ago. Removing only the features and retaining the basemap and trying the download again sometimes results in the same apparent download with the error on opening, or sometimes results in the error "The map 'XXXXX' failed to download with the message: Read timed out"
Using the USA Topo Maps (for Export) Tile Layer by esri (Created: Oct 21, 2013) instead does not seem to make any difference.

Trying to download a 7 MB map area with Collector Classic on a different Android device (Android 6.0) gave the error, "The map 'XXXXX' failed to download with the message: Read timed out"

There might have been other errors given after some of my other attempts. I have tried to download a map more than 10 times since about June 4, 2021, with different combinations of layers, but never successfully.

I rather doubt it is a problem with a layer, since I have downloaded all of these layers (including the USA_Topo_Maps for export layer) in various combinations in other maps, with Collector Classic on this and another Android device, at some point this year. I am using the ESRI World Topo (for export) basemap, which downloaded successfully to this same Samsung Android device in another map.

I have tried the same download multiple times on 2 different WiFi networks, but never was successful.

How can I get a map or map area downloaded so I can use it offline?

0 Kudos
3 Replies
MVP Honored Contributor

Could this have to do with raster basemaps being retired?  You have a date there of 2013 which is prob the raster.  Is there a reason you are not using the Vector basemaps instead?  They will be faster.

Says July 2021so maybe  https://www.esri.com/arcgis-blog/products/arcgis-online/announcements/esris-hosted-raster-basemap-se...



Hope that helps

0 Kudos
New Contributor III

I am using the ESRI World Topo (for export) basemap https://agis.maps.arcgis.com/home/item.html?id=eaee8760ed754019a964a6d785613a50

Not sure if this is vector or not but it is marked Authoritative.

As another layer in the map, I have the USA Topo Maps for export https://agis.maps.arcgis.com/home/item.html?id=ed46209ca47844e2af27b5d5fbedb87b

This might be a raster since it is scanned versions of the USGS quadrangles, but it has worked well for years on mobile devices offline, even just this spring.

I have not seen a topographic vector layer that is as detailed as the USGS 7.5' quadrangles in terms of marking places of interest and contour detail, so I really would like this included in my map.

I tried removing the USA Topo Maps for export layer, but after about 20 minutes, Field Maps just told me "An error occurred when downloading the map"

What am I missing?


0 Kudos
MVP Honored Contributor

I don't think you have to use the for export ones anymore, at least we don't.  Have you tried starting with a brand new map?

The only way to tell if it is raster that I can tell is to go to description in the menu and see what it says.  If you see a list of scales then it is raster.

0 Kudos