Taking Collector 18.0.3 offline on Android 7.0 - java error

02-27-2019 08:03 AM
New Contributor II

On two projects lately I have run into the same error when trying to take a map offline. Sync and permissions are right, I can get through setting the work area extents, once I choose my extents I get the following message in a pop-up:

Map failed to download

The map '[Map Title]' failed to download with the message: Attempt to invoke virtual method 'java.lang.String java.lang.String.toLowerCase(java.util.Locale) ' on a null object reference

This has happened on two maps in the last 2-3 weeks. Any advice on moving this forward would be appreciated.

Tags (3)
10 Replies
Esri Contributor

Hey Tyler. Are you using an Esri basemap or a custom basemap? If custom, try switching to an Esri basemap and see if the issue still occurs.

0 Kudos
New Contributor II

I am using an ESRI basemap.

0 Kudos
New Contributor II

Hi, I have this exact same error on five different Samsung Tab Active 2 tablets. Model SM-T390 Android version 7.1.1. The same AGOL project files work fine on an iOS device.  Any troubleshooting steps we can try? Thanks

0 Kudos
New Contributor II

I tried a few other basemaps and was eventually able to get it to work with three of them. I'm not sure how to reference them but I went to the details of each one and provided the link. Not sure if this helps diagnose the issue. I didn't try all of the basemaps in AGOL.

These work
World Topo farther down the list
World Ocean
National Geographic

These fail with the error or don't show up at all when trying to set the extent
World Street Map
The World topo at the top of the list
World imagery
Streets (night)
Terrain with Labels

New Contributor III

Tyler, did you ever figure this out?

0 Kudos
New Contributor III

I am receiving this same error on a Samsung S10e with Android version 9, Collector for ArcGIS version 18.0.3. I tried to do an Uninstall/Reinstall and still the problem persists. I tried to download on an iPad and that worked. Is there a bug with Androids?

New Contributor III

I figured out my issue...I did not have an extent set for my web map. I had 6 layers in my map and the first 3 added were empty data sets which made my extent global. I zoomed into my project area, saved and then "Voila!" I could download.

Occasional Contributor

I'm having the exact same issue.  I think it has to do with vector tile basemaps.  I can download the standard "World Imagery" correctly, but I cannot download the world imagery + vector tile reference layer.  I think until the beta version of collector for Android has the ability to on-demand download offline areas (as oppose to pre-setting of map areas for download), we will be forced to use non vector tile basemaps for collector.  

by Esri Regular Contributor
Esri Regular Contributor

Since this post is still getting some views, I wanted to mention here that the Android beta does support on-demand downloads. 

Also, the original post was about the released Android app, and as discussed in this thread, it doesn't support vector basemaps. The beta, however, does support them.

0 Kudos