Sync errors with Collector offline

27321
45
Jump to solution
03-18-2014 04:20 PM
CarmaGerber
New Contributor
Hello fellow Collectors!

I am happy to have downloaded the new version of Collector. I have successfully set up a map for offline editing, downloaded it to my device and collected some features.

Seems to be a bit sticky syncing back though. I have had 2 REST API errors (this is what they appear to be) so far relating to sync'ing the replica.

Both appeared to be a rollbackOnFailure error.

The difference being:

1st error - gave me an 'error synchronizing replica' message that contained the GUID for the feature I was syncing (I only had 1 to sync). Then when I checked the map in browser AGOL, the feature I was syncing was there, so perhaps an error that wasn't actually an error.

2nd error - didn't show me a GUID however I was syncing multiple features. These did not appear in my map in the browser, so a genuine error.


Any ideas here?

Carma Gerber
Esri Australia
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor
Are you using copied layers in the web map? The app currently does not support these and could be why you are seeing this issue.

Thanks
Russ

View solution in original post

45 Replies
RussellRoberts1
Esri Frequent Contributor
Can you share your service and I can try to reproduce these sync errors.

Thanks
Russ
0 Kudos
CarmaGerber
New Contributor
Hi Russ

unfortunately I can't share due to the restriction on my organization.

I managed to successfully sync yesterday afternoon.

I have attached the screen shots of the errors.

Carma
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Does your service have requird fields?

Russ
0 Kudos
CarmaGerber
New Contributor
Hi Russ,

No it doesn't.

Carma
0 Kudos
RussellRoberts1
Esri Frequent Contributor
When was this service published? Have  you seen this error with other hosted services?

Thanks
Russ
0 Kudos
CarmaGerber
New Contributor
Hi Russ

I published this service in order to test the Offline capabilities of Collector, so in the last day or 2.

I haven't had the issue with any other service and since I had these errors, I have been able to sync that service, so it was only temporary.

We have loads of clients who are very excited about Collector offline capabilities so I just want to be prepared so that if they experience the same error I can have some troubleshooting ideas ready.

Cheers
Carma
0 Kudos
CarmaGerber
New Contributor
Hi Russ

I seem to be having these issues again with downloading a map for offline use with Collector.

I have shared the map and services publicly for you to have a look at:
https://unitywater.maps.arcgis.com/home/webmap/viewer.html?webmap=4df9a7e5b2ef458c85aed8c6c178eeb6

Kind regards,

Carma
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Are you using copied layers in the web map? The app currently does not support these and could be why you are seeing this issue.

Thanks
Russ
CarmaGerber
New Contributor
Ah yes, I am.

Thank-you so much for this! Great to know.

Cheers

Carma
0 Kudos