Related records not showing in the new collector

1175
8
12-21-2018 12:58 PM
joerodmey
MVP Regular Contributor

I have a web map with a feature with related records that worked in the old collector but not the new collector. Any reasons why this would be the case? 

8 Replies
BrantCarman
Occasional Contributor

I'm having this same issue.  I can see related records for a feature in the web map and in Collector Classic, but when I view the same map and feature in the new Collector, all I get is a message that the related records/features will show up when they are added.  I know they are there, just not showing...

Did you ever figure out what the problem was, or if this is just a bug?

joerodmey
MVP Regular Contributor

It was apparently just a bug. No more information was ever provided to me from support.

BUG-000119344: Unable to add a new related record in Collector for ArcGIS (Aurora). The error states "no collectable layers are visible".

0 Kudos
SupervisorMLTMUA
New Contributor

I am having the same issue where I can see related records in the web map and collector classic, but not in the new collector. I don't believe that bug is related since I am able to add new related records in Collector.

For reference:

  • table related to a feature class
  • 1:1
  • simple
  • user-defined IDs (not globalIDs)
  • notification: none (no messages propagated)
  • feature service has create and update enabled

Has anyone found a work around for this? I have successfully had related records appear in Collector before but can't get this one to work. 

TerryMagnussonTOL
New Contributor II

I worked with Esri on this issue recently, and they found that if you refresh the map on the device after initially opening the map, you will see; be able to add and edit related records. It's the initial load that is buggy in iOS devices.

JaredTaylor
New Contributor III

Reloading the map and toggling the "Show Related Types" sstill does not allow me to view the related records, even though I can see them in AGOL and Classic.

0 Kudos
TerryMagnussonTOL
New Contributor II

This is unfortunate in that the New Collector has the ability to copy related records which is why we pushed out the New Collector...and then could not rely on it. I hope this gets fixed soon please!

0 Kudos
MartinSirkovsky1
New Contributor III
I have experienced the same issue. First time the solution was to remove domains for editor tracking fields (creator and editor fields). However, I run into same issue today and editor tracking was disabled, so there couldn't be an issue with editor tracking.
After investigating further, I have found out that one of the fields which had a domain assigned, contained values which were not present in the domain. Once I have removed the domain from the field, I was able to see related features in new Collector for ArcGIS.
 
Without any further testing, it seems that related data cannot be accessed from Collector, when there is a domain assign to a field, but some values in the field are not present in that domain. In any case, I would recommend to remove all the domains from the related table, republish the service and see what happens. If it works, you can start to add domain one by one and see which causes the issue.
 
Generally, it could be said, that the domains are causing lot of issues in new Collector for ArcGIS. So anytime I have problems, I am trying to remove the domains, and in most cases, I find a domain which causes issues with the map.
0 Kudos
AhjungKim4
Occasional Contributor II

We had a similar issue (04/2020) with the latest version of new Collector for iOS.  Field staff added related records with no problem in the AM, but it stopped working in the afternoon.  Refreshing or reloading maps did not fix it.  We checked and confirmed related records could be added within the Classic Collector using the same map. However, we needed the snapping from the new Collector, so I created a new webmap quickly. This resolved the issue, but I am anxious it is going to happen again while field staff are out in the field.  

0 Kudos