Re: Not receiving any locations in Collector on Android when using the Eos Arrow Gold receiver.

1735
6
Jump to solution
05-23-2019 02:54 PM
DanielHunter
New Contributor III

I am having the same issue.  I just unpackaged a Samsung Tab A along with EOS Arrow Gold receiver.  When I switch from EOS Tools Pro app to the Collector (Beta or Classic) my device loses the connection.  I've confirmed my new receiver works fine using Collector (and Classic) on iOS hardware...Whats going on?  

0 Kudos
1 Solution

Accepted Solutions
Jean-YvesLauture
New Contributor III

Hello Daniel, 

Further to what Kevin has replied above regarding the Eos Arrow Gold, here is a link to a video tutorial for the configuration he described: https://eos-gnss.com/configuring-esri-collector-on-android-with-your-arrow-receiver/

This link is also useful: https://eos-gnss.com/mock-location-android-eos-tool-pro/

And some explanation of how it works: https://eos-gnss.com/how-to-collect-gnss-locations-android-app-for-arrow/

Next...

Make sure that you are able to see the metadata from the Arrow Gold in the real-time location pop-up of Collector (similar to what you see in the above video at the 4:10 time mark). If you are able to see the metadata in this window this means the Arrow is indeed sending proper information to Collector via the Mock Provider.  

Then... 

In order to get the GNSS metadata recorded, you must first prepare your maps to have the proper fields. Here are some helpful links (just in case): 

1) Esri Water webinar (dated 2016) with Jeff Shaner presenting the required steps in ArcGIS Online: https://eos-gnss.com/esri-water-meetup-webinar-arcgis/

2) An Eos Guide: https://eos-gnss.com/recording-gpsgnss-metadata-arcgis/

Plus... 

If you need to record Orthometric Heights using the Geoid12B model for the USA, here is the solution page with some helpful links: https://eos-gnss.com/product/solutions/geoid-height/

(Note that for Android, until Collector Aurora is made available with support for the Z-value, the orthometric height (if activated in Eos Tools Pro) will be recorded in the ESRI_GNSS_ALTITUDE field (which normally expects ellipsoidal heights).)

Hope this helps. Good luck. 

Jean-Yves

View solution in original post

0 Kudos
6 Replies
KevinBurke
Esri Contributor

Hi Daniel,

The issue you're running into, although seemingly similar to the issue others are seeing with the Trimble R2, is actually slightly different and is expected to happen on Android. I am still investigating the behavior with the R2 that others are seeing. 

The main reason is that on Android, both Collector and the Eos Tools Pro apps are trying to consume the BT connection to the Arrow simultaneously which is causing a BT contention issue where one app gets kicked off when the other is using it. 

iOS does not have this BT contention issue, mostly because it's just unique to how that OS works compared with Android. 

Therefore here is the workflow to follow in this case (I am also using a Samsung Galaxy Tab A running Android 8.1, so my steps might slightly differ if you're using an older version of Android):

1. Pair the Eos Arrow receiver with the Samsung Tab A and connect it through the Eos Tools Pro app, like you're doing normally, and configure the RTK settings.

2. On the Samsung device, go to Settings >  About Tablet > Software information > Tap several times on Build number, eventually you will enable Developer options.

3. Go into Developer options > Mock location app > choose the Eos Tools Pro app.

4. Back in the Eos Tools Pro app > click the overflow menu (three dots) in the upper right corner and choose 'Enable Mock Location'

5. Then in Collector, for the Location Provider, use the 'Integrated Receiver' and not the Eos Arrow device directly.

6. Once you obtain a fix, you should see the Eos Arrow being used to provide the locations to Collector through the mock location provider. 

Let me know if you have any other questions.

Thanks

-Kevin

DanielHunter
New Contributor III

Kevin this worked well - thank you.  The high accuracy fields in my feature layer are not documenting any receiver metadata though... thoughts?

0 Kudos
Jean-YvesLauture
New Contributor III

Hello Daniel, 

Further to what Kevin has replied above regarding the Eos Arrow Gold, here is a link to a video tutorial for the configuration he described: https://eos-gnss.com/configuring-esri-collector-on-android-with-your-arrow-receiver/

This link is also useful: https://eos-gnss.com/mock-location-android-eos-tool-pro/

And some explanation of how it works: https://eos-gnss.com/how-to-collect-gnss-locations-android-app-for-arrow/

Next...

Make sure that you are able to see the metadata from the Arrow Gold in the real-time location pop-up of Collector (similar to what you see in the above video at the 4:10 time mark). If you are able to see the metadata in this window this means the Arrow is indeed sending proper information to Collector via the Mock Provider.  

Then... 

In order to get the GNSS metadata recorded, you must first prepare your maps to have the proper fields. Here are some helpful links (just in case): 

1) Esri Water webinar (dated 2016) with Jeff Shaner presenting the required steps in ArcGIS Online: https://eos-gnss.com/esri-water-meetup-webinar-arcgis/

2) An Eos Guide: https://eos-gnss.com/recording-gpsgnss-metadata-arcgis/

Plus... 

If you need to record Orthometric Heights using the Geoid12B model for the USA, here is the solution page with some helpful links: https://eos-gnss.com/product/solutions/geoid-height/

(Note that for Android, until Collector Aurora is made available with support for the Z-value, the orthometric height (if activated in Eos Tools Pro) will be recorded in the ESRI_GNSS_ALTITUDE field (which normally expects ellipsoidal heights).)

Hope this helps. Good luck. 

Jean-Yves

0 Kudos
DanielHunter
New Contributor III

Jean - This is a huge help.  Thanks for consolidating all the links into this post.

Jean-YvesLauture
New Contributor III

You’re welcome Daniel. 

0 Kudos
KevinBurke
Esri Contributor

Hi Daniel,

I am going to break this issue out into a new thread, because this behavior is different than what is happening with the R2. This was broken out from https://community.esri.com/thread/227756-collector-with-trimble-r2-record-correct-gnss-receiver-name...

Thanks

-Kevin