Offline Map Sync Error

08-07-2017 07:18 AM
New Contributor II

I have 2 offline maps that were downloaded to my tablet within the collector app. One of the maps syncs just fine and has no issues. The other map gives me an error when trying to sync.

The error is: Unable to synchronize replica., Importing delta data changes failed.

The map that will not sync has a point layer that has 14 edits to sync as well as several photo attachments.

Is there a way to fix this error without losing the data on the tablet?

I appreciate any help.

Jeff Lewis

Tags (1)
5 Replies
New Contributor II

I'm having the same problem the error I'm receiving the the following:

"An error occurred while synchronizing edits - Unable to synchronize replica. - Importing delta data changes failed."  

I cannot find any solution online, and I'm having no success trying to contact ESRI. 

0 Kudos
Occasional Contributor II

I also just came across this same error with an offline map for manhole collection. I was also unable to find a solution and ended up overwriting the feature layer.

The guys were less worried about the 21 features that still needed synced and wanted to get out collecting new features.

New Contributor II

So I figure out what happened.  I had a copy layer on my map, and the arcCollector recognized both layer as the same. All the editing I had on the layers were considered duplicates, nevertheless I didn't want to loose everything. 

The way to do is to plug you phone of tablet in the computer and go to Itunes (or whatever manager software your equipment uses). Here How To: Access offline edits from Collector for ArcGIS directly from an Android or iOS device  has how to do that.

After I got the folder I need I used the Copy Runtime Geodatabase To File Geodatabase tool (convertion tools-->to geodatabase-->Copy Runtime Geodatabase To File Geodatabase). 

Make sure your folder is on the C: drive and your new geodatabase is saved there too. (not sure why this does make a difference however it does and only worked for me on the C:)

After that everything worked like a charm.

0 Kudos
Regular Contributor

I have the same problem. What did you figure out? You had 2 copies of the same layer in the same webmap? 


0 Kudos
New Contributor II


I don't remember if I had 2 of the same layer in the map or not. Unfortunately, I was not able to find a fix and wound up losing the data. Luckily for me, it wasn't a large amount of data and I was able to re-collect it fairly easily. Someone did post a workaround in a post above, however I did not try it. Sorry I couldn't be of more help.

0 Kudos