Layer will not load using Portal

1307
13
Jump to solution
10-10-2017 10:19 AM
KellyPilarski
New Contributor III

We have not successfully been able to use collector. The maps show up in the program , but the layers will not turn on or load. The layer is visible in the layer menu, but does not allow you to click the check box to turn it on. Portal MapLayer added

0 Kudos
1 Solution

Accepted Solutions
KellyPilarski
New Contributor III

The issue ended up being that port  6443 was not allowed past the firewall, therefor all external connections like Collector were not seeing data that was trafficked through the SQL server on 6443. We did not notice this right away due to the fact our feature layers that were not on SQL server were coming through just fine. 

View solution in original post

0 Kudos
13 Replies
TiffanyRufo
Occasional Contributor II

You may want to double check your sharing settings to make sure that the account you are logged into is part of the group(s) the map is shared to.

When the layer was uploaded to ArcGISOnline were the boxes for create, delete, update and/or sync checked?

0 Kudos
KellyPilarski
New Contributor III

SharingScreen

It is a Portal account not an Online account, so that area is grayed out on export.  Is there a work around for this?

0 Kudos
TiffanyRufo
Occasional Contributor II

I don't have any experience with Portal unfortunately....So I'm afraid I won't be any help on that front....But is there a way for you to log in to Portal to view your maps and feature services?

You should be able to adjust the share settings from there if you can get to where the feature services are hosted.

0 Kudos
KellyPilarski
New Contributor III

Share

Yes there is. the layers appear in all the web maps, just not collector. 

0 Kudos
TiffanyRufo
Occasional Contributor II

If you can find something like this^ you should be able to open the feature layer to a page like this:

Open the settings tab and you should be able to check the editing capabilities as well as tracking:

Sorry this is the best I can offer not knowing how Portal works...

0 Kudos
KellyPilarski
New Contributor III

settings

The settings tab does not include editing .

0 Kudos
TiffanyRufo
Occasional Contributor II

Ok, so just to cover all of the bases, when you publish your feature layers through Portal are you checking the boxes to enable create/delete/update in the feature access tab? Like here:

0 Kudos
KellyPilarski
New Contributor III

Feature Access

Correct

0 Kudos
TiffanyRufo
Occasional Contributor II

Hmmm, that is frustrating isn't it... Honestly, those were my best guesses not having worked with Portal...Sorry I haven't been much help. I think we need someone who knows more: Anyone else? 

Portal for ArcGIS‌ https://community.esri.com/community/gis/applications/collector-for-arcgis?sr=search&searchId=a70f1e...

0 Kudos