Select to view content in your preferred language

Issues with Web Layer in Collector/AGOL causing both drawing and offline issues

07-08-2021 03:44 PM
by Anonymous User
Not applicable

Good Afternoon Everyone,

So I'm having an issue with a web map and the related feature layers that I can't seem to get a handle on how to fix. The map has three main layers/components:


- Roads

- Road Gates

- An empty point feature set to record Road Repair Needs (has photo attachments enabled)


Each layer is in the map twice. The upper layer is a standard symbol with no variation, the lower layer is colored to indicate the status of the road/gate/repair. I've been noticing a number of cascading issues with the map and think they may all have the same instigating issues, but cant put my finger on it:

1. The Roads Layer is for a large (700k acre) area, but very spread out. At full zoom it isn't drawing completely. Optimizing Layer Drawing helped with this issue, but it persists whenever I try to create offline areas.

2. For some reason when I disable editing on the roads layer in the map when I try to create a "read-only" copy for a different group, the layer refuses to draw at all. It doesn't appear to be an issue with the point gates data, just the roads.

3. Most frustratingly of the bunch, offline areas have been impossible. I've tried lowering the size of the area, the resolution, and it doesn't matter. I removed the duplicate color coded layers, still no dice. When I do succeed in creating the offline area I try using it on my phone only to find none of the layers are actually showing any data, or at most are showing just some of the color coded roads, but none of the gates. 


I've tried identifying what Layer is causing the issue by isolating them in separate maps:

Gates Data: Map doesn't even show up in collector despite being enabled for offline use with a offline area created.

Roads Data: Same issues as the complete map.

Road Repair: Empty set, seems to load fine.


All the layers have the identical settings for editing: enabled, all tracking and sync enabled, Add/Update (No Delete), editor can see and edit all features, and anon editors have same permissions.


I'm happy to share more info/data, but I can seem to figure out what is causing the problem. Any and all help would be greatly appreciated. Thanks!


0 Kudos
1 Reply
Esri Contributor

@Anonymous UserI look forward to meeting with you later today.  Regards, Charmel Menzel

0 Kudos