Feature layer is not able to be selected/edited after being submitted in the New Collector

551
2
05-24-2019 09:53 AM
Katherine_Clark
MVP Regular Contributor

Hello,

I published a hosted feature layer with ArcMap that includes a point, line, and polygon layer for field data collection. This layer has worked fine in Collector Classic for data collection, and there is no issue in Classic with being able to tap the feature to view its attributes/pop up or to edit the feature. However, this is not the case in the New Collector. In this case, once you submit a feature, you are unable to select or edit anything in the layer. This behavior has happened in several different web maps that are used offline.

The user that is trying to edit the data is a Creator user type with a Publisher role. I also confirmed that editing is enabled for the feature layer where editors can add, update or delete features.

Any idea what could be causing this behavior? Thanks in advance for any input!

0 Kudos
2 Replies
AllisonKampbell
New Contributor III

I also came across this issue today.  I have a polygon feature class that participates in a Many to Many relationship class.  I can create a new polygon, but once submitted, I can not edit the polygon in the new collector.  In collector classic I am able to edit the polygon.  I am not sure if the relationship class had something to do with the editing issue. 

0 Kudos
Katherine_Clark
MVP Regular Contributor

Thanks for the insight. In my case, there were no relationship classes involved with the layer. I ended up just publishing a new data collection layer for the colleague to use since we were never able to figure out what caused the issue with the original layer.

Good luck!

0 Kudos